Request queue header is way too wide

RESOLVED FIXED in Bugzilla 2.20

Status

()

defect
--
trivial
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: timeless, Assigned: wicked)

Tracking

2.17.6
Bugzilla 2.20
Dependency tree / graph
Bug Flags:
approval +
approval2.20 +

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
If "Request Queue" is taken out of the table, it's almost not bad. That's what
I'd like to do.
(Reporter)

Comment 1

16 years ago
Posted image picture of problem

Updated

14 years ago
Assignee: timeless → myk
Component: Attachments & Requests → User Interface
OS: Windows 2000 → All
QA Contact: mattyt-bugzilla → default-qa
Hardware: PC → All
Yes, I agree. :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
This may be as simple as taking the big filter_form block and moving it under
the 'PROCESS global/header' block, since for some reason the big filter_form
table is being used as the h2.
(Assignee)

Comment 4

14 years ago
Urgh.. It sure is a great idea to use a form inside a h2 tag. That won't fly for
very long.. Both HTML 4.01 standard and validity check agrees with me:

line 86 column 5 - Warning: missing </h2> before <form>
line 161 column 8 - Warning: discarding unexpected </h2>
line 86 column 5 - Warning: trimming empty <h2>

I looked and luckily it seems request.html.tmpl is the only one abusing h2 tag
(atleast when passed to header.html.tmpl). I can fix this, unless myk is just
about to attach a patch.. :)

BTW, this change seems to have been introduced by myk in bug 179360.
Assignee: myk → wicked
Blocks: bz-validhtml
Severity: normal → trivial
Target Milestone: --- → Bugzilla 2.22
(Assignee)

Comment 5

14 years ago
Attachment #193144 - Flags: review?(LpSolit)

Comment 6

14 years ago
Comment on attachment 193144 [details] [diff] [review]
Move filter form below h1, V1

r=LpSolit
Attachment #193144 - Flags: review?(LpSolit) → review+

Comment 7

14 years ago
The patch applies cleanly to 2.20. Makes sense to have it there too.
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval2.20?
Target Milestone: Bugzilla 2.22 → Bugzilla 2.20
yes! been waiting for this one. :)
Blocks: rt-clean-up
Flags: approval?
Flags: approval2.20?
Flags: approval2.20+
Flags: approval+

Comment 9

14 years ago
tip:

Checking in template/en/default/request/queue.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/request/queue.html.tmpl,v
 <--  queue.html.tmpl
new revision: 1.13; previous revision: 1.12
done

2.20rc2:

Checking in template/en/default/request/queue.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/request/queue.html.tmpl,v
 <--  queue.html.tmpl
new revision: 1.12.6.1; previous revision: 1.12
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
*** Bug 184403 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.