Closed Bug 226602 Opened 18 years ago Closed 17 years ago

Need Document Icons for Firefox

Categories

(Firefox :: General, defect, P1)

PowerPC
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox1.0

People

(Reporter: bugs, Assigned: bugzilla)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(5 files, 11 obsolete files)

66.27 KB, application/octet-stream
Details
46.45 KB, application/octet-stream
Details
11.66 KB, image/png
Details
1.19 KB, patch
Details | Diff | Splinter Review
81.44 KB, application/octet-stream
Details
We need document icons for Firebird's assocations for MacOS X and Windows. Linux
can ride along with Windows. 

We need several sizes for the different platforms, see bug 226601 for a matrix. 

Here are the icons required:

- HTML/XML document
  Windows:
   this must have the *standard Windows document look* with a smaller Firebird
motif overlaid. 
  MacOS X
   this must have the *standard OS X document look* with a smaller Firebird
motif overlaid.
- XUL document
  Ditto above, but perhaps a different motif to indicate XUL. 
- XPI
  Icon style appropriate to Windows/Mac to indicate a package containing
extension/theme content. 

When I say "standard <platform> document look" I mean that the document
component of icon should look as if it had shipped with the OS - the same style
as others. This is so that we seem to integrate with the OS cleanly rather than
being a foreign intruder. 

Mac icons should be high detail, high quality and perhaps have an aqua look.
Dupe of bug 214054 or vice-versa?

Summary: Firebird -> FireFox?

See also bug 99380 for ideas (Mozilla icons) and the attachments (examples
attachment 129323 [details] and attachment 129116 [details]). Those are Win32 icons designed for
Seamonkey or if Firefox replaces Mozilla Browser in a later version.
Summary: Need Document Icons for Firebird → Need Document Icons for Firefox
*** Bug 214054 has been marked as a duplicate of this bug. ***
Flags: blocking0.9?
Attached image .gif file icon (obsolete) —
Attached image .jpg, .jpeg, .png, .mng file icon (obsolete) —
Attached image .htm, .html, .xhtml file icon (obsolete) —
Attached image .xbm file icon (obsolete) —
Attached image .xml file icon (obsolete) —
Attached image .xul file icon (obsolete) —
Document icons are now in and working on Windows in recent nightlies. However,
they don't seem to be there yet on OS X.
This is a minor polish bug. It certainly shouldn't block Firefox 0.9 which is a
feature-driven release. If it makes it in, great. If not, we shouldn't hold off
0.9 for this.
Flags: blocking0.9? → blocking0.9-
Flags: blocking1.0?
Changing platfomr since this is now Mac only
Flags: blocking1.0? → blocking1.0+
OS: All → MacOS X
Hardware: All → Macintosh
*** Bug 242814 has been marked as a duplicate of this bug. ***
Priority: -- → P1
Target Milestone: --- → Firefox1.0
Attachment #142762 - Attachment is obsolete: true
Attachment #142763 - Attachment is obsolete: true
Attachment #142764 - Attachment is obsolete: true
Attachment #142765 - Attachment is obsolete: true
Attachment #142766 - Attachment is obsolete: true
Attachment #142767 - Attachment is obsolete: true
I have posted proposed MacOS X icons on the MozillaZine forums here:

http://forums.mozillazine.org/viewtopic.php?t=78228

Could Ben/Blake please look at them and let me know if they're what they're
looking for and if I should continue to work on them?

Cheers,
Will Ryan (WiLLBERT)
I converted Will Ryan's icon images into .icns icon files for Mac OS X.
Flags: blocking1.0+ → blocking1.0mac+
Shouldn't all those icons have the Firefox icon in them? The bear in the JPEG
icon for example doesn't tell the user which application will be launched when
the JPEG document is double-clicked.
(In reply to comment #15)
> Shouldn't all those icons have the Firefox icon in them? The bear in the JPEG
> icon for example doesn't tell the user which application will be launched when
> the JPEG document is double-clicked.

Yeah, that's true.

document icons:
http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGIcons/chapter_13_section_2.html#//apple_ref/doc/uid/20000967-TPXREF124

icons for plug-ins:
http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGIcons/chapter_13_section_2.html#//apple_ref/doc/uid/20000967-DontLinkElementID_356852

I think that the XUL one is particularly a problem along those lines, since
looks almost identical to Apple's icon for Terminal, which would pretty easily
lead one to believe that the document will open with Terminal, or has something
to do with Terminal.
All the document icons with the Firefox icon in it. I don't know whether XPI
and XUL are plug-ins or not, so I made both document and plug-in icons for
them. Pick the appropriate one.
Attachment #149352 - Attachment description: Firefox Document Icons → Firefox Document Icons (sorry, buggy shadow)
Attachment #149352 - Attachment is obsolete: true
Attached file Firefox Document Icons Mac OS X (obsolete) —
Sorry, previous had buggy shadows. These are the ones that should be used I
think.
Those new icons are very nice.  Just a few things:

The XUL one should use the document icon (those have XML/text contents).

There should also be a TEXT document icon, I think.

XPI files aren't really documents or plugins, but archives for installers.  So
perhaps starting with a package-type icon would work, like the one in
Installer.app/Contents/Resources/package.icns?  Or perhaps it should be a plugin
type icon, since the archive contains install scripts, and hence kind of "runs"
in a sense?  I'm not sure...
Attached file Firefox TEXT icon Mac OS X (obsolete) —
Attached file Gnome Linux Icons
I realise you said that Linux icons could ride along with Windows, but in
Gnome, the default icons look very different to the Windows icons. So, I
created these icons, one for all documents and one for an XPI package. I've
included the original .psd files (with and without the badge for the document
icon) and .png images of what the completed icons look like for people who are
just curious.

Cheers,
Will
Here is the official Firefox document icon for OS X. It is my understanding
that Firefox will only be the default application for HTML, XHTML, and XUL
files - so other format icons for Firefox are not necessary (the rationalle
being that the OS provides better image preview apps already).
Attachment #149168 - Attachment is obsolete: true
Attachment #149358 - Attachment is obsolete: true
Attachment #149364 - Attachment is obsolete: true
(In reply to comment #22)
> Created an attachment (id=152436)
> Official Firefox document icon for [..] HTML, XHTML, and XUL
> files - so other format icons for Firefox are not necessary

And what is the rationale for not showing the file type in the document icons
for these types as most other OS X documents icons do?
(In reply to comment #23)
> And what is the rationale for not showing the file type in the document icons
> for these types as most other OS X documents icons do?

Right, this is fine as an icon *template* but it's not a legit actual document
icon.  There needs to be one for each document type, based off of that template,
with the file type text included.  Actually, I will just do that myself later
tonight...

Regarding the image documents, yeah, it's not necessary for those.  Though there
is a reason to do it which is for image files that have Firefox's creator code
('MOZB'), so then they will be associated with Firefox (regardless of whether
Preview or anything else is by default the associated app for a file type), and
then the file could show a Firefox document icon, which would be accurate. 
Anyway, I'm not saying that it's worth bothering with that, the other document
types are more important, but just explaining the reason why one might still
want to provide icons and association data in the Info.plist for image files...
(In reply to comment #24)
> Right, this is fine as an icon *template* but it's not a legit actual document
> icon.

Here's a reference:
http://developer.apple.com/documentation/LegacyTechnologies/Conceptual/AquaHIGuidelines/AHIGIcons/chapter_11_section_2.html
(In reply to comment #24)
> Right, this is fine as an icon *template* but it's not a legit actual document
> icon.  There needs to be one for each document type, based off of that template,
> with the file type text included.  Actually, I will just do that myself later
> tonight...

I included the Photoshop template in
http://bugzilla.mozilla.org/attachment.cgi?id=149358&action=view here already.

Documents that Firefox defines in its Info.plist should have its own custom
icon. The type is useful information - especially when you consider that
completely different things happen when you open a HTML and a XUL document.
Target Milestone: Firefox1.0 → Firefox1.0Mac
(In reply to comment #10)
> This is a minor polish bug. It certainly shouldn't block Firefox 0.9 which is a
> feature-driven release. If it makes it in, great. If not, we shouldn't hold off
> 0.9 for this.

How is this coming along?
I disagree with the above that this is "minor polish". On the Mac platform it
makes the app look sloppy that it doesn't provide its own document icons. 

The photoshop template for Mac icons in post #26 looks fantastic. Any chance at
least the basic HTML, XHTML, GIF, & JPEG icons get make it in for 1.0? This
really shouldn't take long. I have just managed to add the 'basic'
firefoxdoc.icns file to my installation of Firefox 1.0PR by doing the following:
* open Firefox package
* copy the icon file into the Resources folder
* rename it to "document.icns"
That's it!
I get the same icon for all things that open with firefox, but at least I can
now see they open with firefox. Different icons for different documents would
just mean editing the info.plist file.
Attached image Proposal for Mac document icon (obsolete) —
I have a suggestion for the icons for Mac OS X:

For XUL and XPI, use the 'plug-in' icons as in the zip file (comment #26)
For JPEG and other images, use the 'bear' icon from the forum post (comment
#13), but replace the actual picture of a bear with something that indicates the
application that will open the document. Perhaps the photograph illustrated in
the icon could be a photograph of the firefox icon. I don't think we need to
distiguish graphically between GIF-type images and JPEG-type images. But the
'set square' icon from that forum post could be used later on when Firefox opens
SVG files.
For HTML, XHTML, XML, etc, use something similar to the Mac OS TextEdit HTML
icon, but with the globe replaced with the Firefox logo, and with a filetype
identifier at the bottom (see my attachment in comment #28 -- but bear in mind
it's a quick mock-up and the shadows overlap badly).

This will go some way to make it clearer what sort of contents a file has: a
'document' or a 'picture', as well as giving the actual extension code for the
more experienced user.

If you need someone to make the changes to the Mac OS X info.plist file, I
volunteer.
Improved version of my proposal.
The miniature text is taken from the main Mozilla site.
Attachment #160051 - Attachment is obsolete: true
I think that #30 looks great and agree with all of #29's suggestions.
Quote from post 28:
"replace the actual picture of a bear with something that indicates the
application that will open the document"

Actually, the picture is of an actual firefox, but yeah, it didn't look as good
on paper (or computer) as I thought it would.

I agree with your post too, however it doesn't affect me much being a Windows
user, hehe.
The document icons (official and non-official) are already in the tree, but the
Makefile doesn't copy the document.icns into the app bundle when the regular
app icon is copied in. Here's a patch to make that happen. It's a start. We can
get more elaborate document icons later.
Comment on attachment 161687 [details] [diff] [review]
Patch for browser/app/Makefile.in

Ben, can you give this a quick look please?
Attachment #161687 - Flags: review?(bugs)
The official Firefox icon has changed a little. See
http://forevergeek.com/geek_articles/firefox_logo_tweaked.php
These icons relect those changes.
We're not accepting new artwork at this time. Requesting 1.0 blocking so the
relatively low risk patch can be considered.
Flags: blocking-aviary1.0+
checked in. 
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Keywords: fixed-aviary1.0
looks good on linux fc2 (2004110309-0.11). but on mac os x (10.3.5) I had to do
some extra steps:

1. save an html file to desktop.
2. click html file icon and hit cmd+I. (currently labeled as a Safari doc)
3. changed the "Open With" to today's Firefox build.

after which it displayed the firefox emblem.
verified with Windows FF build 2004-11-04-06-0.11
Status: RESOLVED → VERIFIED
Flags: blocking0.9-
Flags: blocking-aviary1.0mac+
Target Milestone: Firefox1.0Mac → Firefox1.0
You need to log in before you can comment on or make changes to this bug.