alert/confirm/prompt dialogs don't have focus/do not react on enter

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: martin.honnen, Assigned: danm.moz)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When using the javascript dialogs alert/confirm/prompt the dialog window comes
up but doesn't have the focus.
With dom level 0 browsers they have and pressing enter clicks the default button
in the dialog. With M12 on win98 you need to use the mouse to press the buttons
in the dialog.

<BUTTON ONCLICK="alert('Kibology');">
alert
</BUTTON>
<BUTTON ONCLICK="prompt('Name', 'Kibo');">
prompt
</BUTTON>
<BUTTON ONCLICK="confirm('Kibologist?');">
confirm
</BUTTON>

It might be more a user interface/dialog issue than a dom level 0 one but I am
uncertain about a fitting category.
(Reporter)

Comment 1

19 years ago
Created attachment 3829 [details]
bug demo

Updated

19 years ago
Assignee: vidur → danm

Comment 2

19 years ago
Dan, is this your bug? If not, please reassign and let me know who owns the
dialogs for future reference.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

19 years ago
Can't reproduce with today's build. I assume this was some transient problem with
key bindings. That code is thoroughly under development and breaks every now
and then.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified with 2000-01-11-09.
You need to log in before you can comment on or make changes to this bug.