.dll tries to download rather than executing on target server

RESOLVED INVALID

Status

SeaMonkey
Download & File Handling
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Tobias Bjerregaard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

In the webmail application MailMax (v4.1) I tried to read a mail. The link to
read a mail is to a certain file xxx.dll on the server, which should execute (on
the server) with passed arguments. Instead, Mozilla asks whether to save the
file (xxx.dll) or to choose a program with which to execute it. Opera 7.23 does
the same, but I tried with Mozilla 1.0.1, which does not have this problem. I
run redhat 8.0 on a PC-machine.

Reproducible: Always

Steps to Reproduce:
1. Clicking a .dll link from a webpage should do it.
2.
3.

Actual Results:  
The download manager asks whether to save the target, or execute it.

Expected Results:  
Mozilla should do nothing, the .dll should execute on the server. Mozilla 1.0.1
behaves in the proper manner, thus it seems a problem which has occured in some
newer version.

I havn't been able to find equivalent bugs, even if it seems it should be a
problem in many database type web applications. I havn't been able to find a
work-around.
> Opera 7.23 does the same, but I tried with Mozilla 1.0.1, which does not have
> this problem

Most likely a bug in Mozilla 1.0.1.

Note that the .dll _does_ execute on the server; what we are offering to save is
the output it produces.  Please use a recent build (1.6a; 1.5 may not be recent
enough for this) and look at the _exact_ text in the dialog you get.  What does
it say?

Comment 2

15 years ago
A link would also be useful, though I can see why that'd be hard to provide. I 
imagine that the server is returning a response with an unknown content type 
(or possibly application/octet-stream), and so Mozilla is offering to download 
or run it.

Note that IE attempts to 'guess' the correct content type, so if it's an HTML 
document, for example, you might not see the problem with IE.
(Reporter)

Comment 3

15 years ago
I see how the dll does execute, and saving and renaming the file that is
returned, it turned out that it is actually an html file, displaying the email
that I required! Never the less, this 'work-around' seems a bit akward!
The exact wording from Mozilla is:

The file "mmweb.dll" is of type application/octet-stream, and Mozilla does not
know how to handle this file type. This file is located at:
http://xx.xx.xx.xx/webmail/
What should Mozilla do with this file?
O Open it with ...
OSave it to disk

Any ideas of why it does just display it?
Any ideas to what I could do?
Thanks :-)
> Any ideas of why it does just display it?

Because the server says it's application/octet-stream

> Any ideas to what I could do?

Get the guy who wrote that DLL to send the real contnet-type (or send no type at
all so that we can detect it ourselves).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.