no error dialog when iframe page has a DNS/connectivity error.

VERIFIED DUPLICATE of bug 14696

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 14696
19 years ago
18 years ago

People

(Reporter: Dritan Suljoti, Assigned: Judson Valeski)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If the src of the iframe has a DNS error, or connect to host error, the browser
says that it contains unrecognized file type, and says if you want to save it.

If you say no, and stay on the page a little longer the browser crashes.

Ideally should give an erro page, or alert and show the rest of the page,
leaving the iframe empty.
(Reporter)

Updated

19 years ago
Severity: normal → minor
(Reporter)

Comment 1

19 years ago
not related to iframes. It was actually when you open a local webpage, and than
try to close the left menu bar. I think this issue is already opened.

As abou the iframe with the error, it does not seem sto crash, but neither shows
an error...

anyway can you really look in seeing what really supposed to happen?

Updated

19 years ago
Severity: minor → critical

Updated

19 years ago
Assignee: karnaze → pollmann

Comment 2

19 years ago
Reassigning to Eric.

Updated

19 years ago
Assignee: pollmann → valeski
Summary: browser crashes when the iframe page has a DNS/connectivity error. → no error dialog when iframe page has a DNS/connectivity error.

Comment 3

19 years ago
I see no unrecognized file type dialog, and no crash, only an empty box drawn
where the iframe should be, and an error message to the console, guess this was
fixed!  :)

Error loading URL http://www.richmedia-ads.com/dc/net5iframedns.html
Document: Done (0.946 secs)

This leaves your request for an error dialog, which seems somehow like bug
17697, so I'll assign Jud in hopes he might know what to do with it?  Jud, is
there some central place that net loading errors like this are going to pop up
dialogs?  Thanks!

Updated

19 years ago
Severity: critical → normal
Component: HTMLFrames → Networking
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Target Milestone: M14
(Assignee)

Comment 4

19 years ago
dialog popping is waiting for webshell changes.

*** This bug has been marked as a duplicate of 14696 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Marking as verified dup of 14696.
You need to log in before you can comment on or make changes to this bug.