HTML mail compose should not attach linked images

RESOLVED DUPLICATE of bug 176416

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 176416
15 years ago
10 years ago

People

(Reporter: Derwood, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031123
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031123

Link means "refer to an object" not "copy an object."  The HTML mail compse
attaches images when the UI refers to this action via the "link" icon.

I understand the reasoning -- it makes sens if the link were a file:// URI but
http:// references should be taken as simple <IMG ...> links and the content not
attached bloating the mail paylode.

Sounds like a new pref is in order so that it mimics the HTML page composer
behavior.  Making people have to context switch is asking for trouble.

Reproducible: Always

Steps to Reproduce:
1. Compose HTML mail
2. Type "This is a link to an image." in the message body.
3. Highlight the word "link" and select "Link/Image" from the toolbar.
4. Use the test URL as a reference.
5. Send the mail.
6. THe image is *attached* to the mail payload.
Actual Results:  
Mail bloat.

Expected Results:  
Done that "really cool internet http thing" and refered to the image like
99.999% of HTML pages in the world do.

I'm not bitter.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 176416 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.