If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

selecting radio buttons on www.ati.com has no effect

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Eugen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

In the page at http://www.ati.com/search/ you have to select a category where to
search a string. In Mozilla clicking on any radio button and starting the search
with "go" results in a message "Please select a section to search.". IE 6 has no
problems here.
There are also other pages on ati.com with this problem; when contacting
customer care by email:
http://apps.ati.com/cservice/webformissue.asp?cboPrePostSales=_PostSales&cmdNext=Continue

Reproducible: Always

Steps to Reproduce:
1. Go to the url.
2. Select a category and enter a search string.
3. Hit "go" to start the search.
Actual Results:  
The message "Please select a section to search." appears.
It's not possible to start a search on ati.com with Mozilla.

Expected Results:  
Behave like IE, start searching for the string.

Comment 1

14 years ago
wfm, 2003111415, Win2k

Comment 2

14 years ago
Confirmed on firebird0.7 in winxp. Marking NEW. Need to investigate.
Status: UNCONFIRMED → NEW
Ever confirmed: true
WFM with a current linux trunk nightly.  Fabian, FB 0.7 and Moz 1.5 are the same
beast.  Please test with a current build, since some document.form.foo stuff has
changed since 1.5....

Comment 4

14 years ago
WFM, latest nightly, WinXP
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031124

I donĀ“t get search results for my searchstrings, would have been fine if you had
included yours in the bug report.
Please give a specific example for Radio-Button and Searchstring working in IE.


Category: Driver Updates      Search: allinwonder             
searched, the after some time something like 'Zero files found' came up.

Category: Driver Updates      Search: Radeon
Category: Driver Updates      Search: Catalyst

produced an error message:

UniFindSearchServer.SearchServer error '80004005'

2A<

/DoSearchFunction.inc, line 124


I know that drivers for Catalyst exist, as I just before used the
'Drivers&Software' menu to select field, OS and product for download.



(Reporter)

Comment 6

14 years ago
Here are some results from searching with IE:

Category: Driver Updates      Search: allinwonder      Results: 0
Category: Driver Updates      Search: all-in-wonder    Results: ~150
Category: Driver Updates      Search: Radeon           Results: ~500
Category: Driver Updates      Search: Catalyst         Results: ~100

Comment 7

14 years ago
wfm  Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031124

Category: Driver Updates      Search: allinwonder      Results: 0     => 0
Category: Driver Updates      Search: all-in-wonder    Results: ~150  => 10/166
Category: Driver Updates      Search: Radeon           Results: ~500  => 10/496
Category: Driver Updates      Search: Catalyst         Results: ~100  => 10/92

Preferences:

Privacy&Security/Cookies: 
Enable all cookies, Limit maximum lifetime to: current session

Advanced/Cache: When the page is out of date

Advanced/Script&Plugins:
Javascript enabled for Navigator only, 
Allow scripts to: all checkboxes checked


regarding my different results in comment #5 using the same browser:
Here I started with an empty cache, and my cache setting changed from 'Once per
Session' to 'When the page is out of date'

You need to log in before you can comment on or make changes to this bug.