Japanese input suddenly dissapears while editing using kinput2 / canna

RESOLVED EXPIRED

Status

()

Core
Internationalization
--
major
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: Andreas Laestadius, Assigned: smontagu)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

When writing japanese using kinput2 -canna, the pre-edit window usually
dissapears (crashes?) after editing a few lines of text.

The only way to bring back japanese input has been to restart the browser.

I have not been able to isolate a specific action that causes this, but I have
so far not been able to enter + 150 characters in one editing session without
this happening.


Reproducible: Sometimes

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 XMODIFIERS=@im=kinput2 mozilla
2. Write some text in japanese in a text area


Actual Results:  
Browser runs with XIM / kinput2 -canna support.
Japanese input seems to crash, and from that point on no input to the text area
in question can be done.

Expected Results:  
Entering japanese text should have been possible as long as XIM was invoked.

Comment 1

14 years ago
You need to identify very precisely what distribution and what version of
kinput2/canna you are using. Did you try to recompile Mozilla locally, or to use
some older version to see if it's a regression ?

Many users are happily using Mozilla to enter japanese characters, so the
problem is something very specific to your installation. Or a bad regression.

Comment 2

14 years ago
You should test too :
export LC_ALL=ja_JP
and
export LC_ALL=ja_JP.eucJP
to see if there's any difference.
(Reporter)

Comment 3

14 years ago
As for my installation (RH9):

Canna-3.6-12
Canna-libs-3.6-12
kinput2-canna-wnn6-v3.1-4
mozilla-1.5-1
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016)

I got the mozilla binaries RPMs for rh9 through yum at:
http://ftp.mozilla.org/pub/mozilla.org/mozilla/yum/SeaMonkey/releases/current/redhat/

As suggested,I have tried different combinations of below, however
all have reproduced the bug (freeze of input). 

#! /bin/bash
# my first post:
# LANG=ja_JP.UTF-8 XMODIFIERS=@im=kinput2 mozilla
#
# tried before posting this post:
# export LC_ALL=ja_JP
# export LANG=ja_JP
# export LC_ALL=ja_JP.eucJP 
# XMODIFIERS=@im=kinput2 mozilla

// I had no problems with mozilla 1.2.1 (before upgrading)
(Reporter)

Comment 4

14 years ago
I have been able to work around this bug in the sense of (successfuly entering
japansese charcters into mozilla) by using UIM and Anthy for
japanese.

Work-around:
# .xsession
# Lets use anthy for ja input
GTK_IM_MODULE=uim-anthy
export GTK_IM_MODULE
 
XMODIFIERS="@im=uim-anthy"
export XMODIFIERS

This work around keeps me from entering swedish umlauts (å,ä,ö) since
default input is now through anthy and seems not be supported.

The I first bug I submitted above seems to be kinput2 / canna 
related.

May I suggest the addition of gtk.immodules support in mozilla?
It would give access to more than one input method per session.



# more on anthy and input method:
http://anthy.dyndns.info/

Comment 5

14 years ago
see bug 164793 for gtk2 input module support.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.