Chatzilla has stopped working

RESOLVED INVALID

Status

Other Applications
ChatZilla
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Mitch, Assigned: Robert Ginda)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6b) Gecko/20031125
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6b) Gecko/20031125

Clicking on the 'cz' icon at the bottom left of the browser, or
using the irc:// URI or Window->IRC Chat menu gives you an all but
blank chatzilla window and javascript messages as so:

Error: client.eventPump has no Properties
Source File: chrome://chatzilla/content/static.js    Line: 968

Error: client.deck has no properties
Source File: chrome://chatzilla/content/handlers.js  Line: 29

And on closing the window i get:

Error: MSG_CLOSING is not defined
Source File: chrome://chatzilla/content/handlers.js  Line: 71

The earliest build i have is cvs 20031110 and it fails from then until now,
but may have broken before then.

Reproducible: Always

Steps to Reproduce:
1. See description
2.
3.

Comment 1

14 years ago
My build from CVS (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b)
Gecko/20031125) is working fine.

Could you check the console for messages "Initializing ChatZilla {" and "}".
Also, if you see "caught exception while initializing:", a copy of the bit
follow it pasted in here would be *very* useful.
Summary: Chatzilla has stopped working → Chatzilla has stopped working
(Reporter)

Comment 2

14 years ago
Created attachment 136406 [details]
ChatZilla screenshot

Absolutely no errors on console. Only errors are theone in the javascript
console shown above. I also note that this works on my Linux build with the
latest 1.6b cvs, so there is somthing else in play here on the Solaris build.
I will do some more investigating.

I've attached a screenshot of the chatzilla window. Note, not even the "File"
menu is available on the chatzilla menu pane.

Comment 3

14 years ago
That screenshot looks just like somthing's died during the init bit (where the
messages I mentioned come from). I'm sure those messages should be on the normal
console or perhaps the JavaScript console, though.

Comment 4

14 years ago
Did you start it from a shell, or from somewhere in your window manager?  (I see
a mozilla button on your toolbar.)  The console that James is referring to is
the shell window that you started mozilla from.
(Reporter)

Comment 5

14 years ago
I started it from a shell, and i did understand what James meant by errors
on the console. Again, i reiterate - there are NO errors on the console shell
from which i started mozilla from when i click chatzilla icon/menu. 

Here is the (lack of messages) from the shell when i start mozilla and click
chatzilla.

 $ mozilla -P md33799
 <nothing more ...>

Even with a different profile/user chatzilla fails. I am rebuilding mozilla
with --enable-logging to see if i can see anything different. I also compared
chatzilla.jar on my Linux and Solaris box and they're the same.

Comment 6

14 years ago
Oh, you need to enable "dump output" in Preferences->Debug.
(Reporter)

Comment 7

14 years ago
Ahm thanks Sam. I enabled Preferences->Debug->Dump Output and i get nothing
strange

cz: Initializing ChatZilla {} 0.002 sec
Setting checks...
Setting Check: urn:prefbar:buttons:colors : true
Setting Check: urn:prefbar:buttons:javascript : true
Setting Check: urn:prefbar:buttons:images : 0
Setting menulist: urn:prefbar:buttons:useragent
Setting checks...
Setting Check: urn:prefbar:buttons:colors : true
Setting Check: urn:prefbar:buttons:javascript : true
Setting Check: urn:prefbar:buttons:images : 0
Setting menulist: urn:prefbar:buttons:useragent
Setting checks...
Setting Check: urn:prefbar:buttons:colors : true
Setting Check: urn:prefbar:buttons:javascript : true
Setting Check: urn:prefbar:buttons:images : 0
Setting menulist: urn:prefbar:buttons:useragent
Setting checks...
Setting Check: urn:prefbar:buttons:colors : true
Setting Check: urn:prefbar:buttons:javascript : true
Setting Check: urn:prefbar:buttons:images : 0
Setting menulist: urn:prefbar:buttons:useragent
cz: Shutting down ChatZilla.


I retried with --enable-logging and still nothing. It fails
with gtk1/gtk2 builds, different compiler, etc.. I have no idea
what's going on ;-(

Updated

14 years ago
OS: SunOS → Solaris
(Reporter)

Comment 8

14 years ago
Ok, after removing each of my extensions individually until i found the culprit,
it has been revealed that "bannerblind" is responsible !!! The bug is reported
here

   http://mozdev.org/bugs/show_bug.cgi?id=4580

Closing this bug as invalid.
Sorry for the confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.