Firebird Ignores Linked Stylesheet if DOCTYPE is Present

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Derek Martin, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The page validates as xhtml 1.0 transitional.

With DOCTYPE in place:
Looks fine in IE6
CSS does not render in Firebird 0.7

Without DOCTYPE in place:
Looks fine in IE6
Looks fine in Firebird 0.7, but now it's not valid xhtml :(

Also, if I use Firebird to File->Save Page As and save the page, a) Firebird
converts my xhtml compliant tags to html tags, and b) It renders the CSS just
fine if I try to view the saved version.

The DTD line I'm using is:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

The stylesheet link I'm using is: 
<link rel="stylesheet" type="text/css"
href="http://192.168.0.6/zamir/common/stylesheet.css" />

I have tried using a relative link to the CSS, to no avail.

Reproducible: Always

Steps to Reproduce:
Not sure. It happens every time for me, but only on this 1 site I'm working on,
and not other sites. I am developing everything on a Windows 2000 Professional
box, with the latest installs of php, apache, and Firebird 0.7.
I don't know what else I can say. It was working fine yesterday, and today it's
not working at all. I haven't changed anything else. I spent 7 hours on this
today, reading articles from alistapart.com, the Netscape dev centre, and W3C.


Expected Results:  
Used the CSS to style all page elements.

If you want, I can send you the file in a .zip, but there's no attach field on
this form. I can't put it online, cause I only have localhost dev abilities,
behind a firewall, and no webspace immediately available (I'm on contract in a
foreign country).

Comment 1

14 years ago
Most likely the CSS is being served with the wrong MIME type.  Mozilla will
forgive this in quirks mode (no doctype) but in standards mode (such as this
doctype) it will ignore the CSS unless it is served as text/css.

Note that the text/css attribute value in the LINK tag makes no difference to
this determination.  The server has to get the MIME type right.

There is a "create a new attachment" right here on the bug page if you wish/need
to attach files.

Comment 2

14 years ago
Use http://web-sniffer.net/ to see what mime type the CSS is sent with.  Also,
check the JavaScript Console in Firebird or Seamonkey to see if there are any
errors like "The style sheet at ... was ignored because its mime type is not
text/css".

-> style system, probably invalid
Assignee: blake → dbaron
Component: General → Style System (CSS)
Product: Firebird → Browser
QA Contact: ian
Version: unspecified → Trunk
(Assignee)

Comment 3

14 years ago
Marking invalid.  Please reopen if you have more information that demonstrates
that this is a valid bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.