Viewer tests missing from Seamonkey installation

RESOLVED WORKSFORME

Status

SeaMonkey
Build Config
P3
normal
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: use leaf@mozilla.org)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
BUILD:
    1999122308 on Win98

TO REPRODUCE:
    Open a Navigator window. Select any of the `Viewer Demos' submenu items in
    the `Debug' menu.

WHAT SHOULD HAPPEN:
    The demos should load.

WHAT ACTUALLY HAPPENS:
    Mozilla progress-bars merrily away forever, because it doesn't yet know how
    to complain about files not existing.

The entire res/samples/ directory has disappeared from the installation. This
may be in preparation for release, but if so then this should be reflected in
the `Debug' menu.

Updated

18 years ago
Assignee: granrose → leaf
Target Milestone: M13

Comment 1

18 years ago
looking at today's win32 build, I don't see any res/samples files there either.
I looked at the packages-win file used to create the package and don't see res/*
or res/samples/* listed, so I'm guessing if they were removed from the package
intentionally but the menu item still needs to be removed.  bonsai is currently
unresponsive so I can't see who might have changed the packages file.

reassigning to leaf as the win32 build god.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
The samples should *not* be loaded on installed, optimized builds. On the other
hand, i don't know of a way to change the ui based on the style of build. CC'ing
people who might have more clue about conditional ui changes. Hyatt?

Updated

18 years ago
Target Milestone: M13 → M14

Comment 3

18 years ago
overlays are in; the infrastructure is there, i don't have time to fix for m13,
though.
(Reporter)

Comment 4

18 years ago
*** Bug 26010 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M14 → M17

Comment 5

18 years ago
mass re-assign of all bugs where i was listed as the qa contact
QA Contact: cyeh → chofmann

Updated

17 years ago
Target Milestone: M17 → ---

Comment 6

17 years ago
this worksforme.  ns doesn't have the debug menu, mozilla tarball and installer
builds have the debug|viewer menu and the tests there work.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.