Closed Bug 226846 Opened 18 years ago Closed 18 years ago

FEATURE REQUEST -- Quit Confirmation dialog box

Categories

(SeaMonkey :: General, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 39057

People

(Reporter: justin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007

Would it be possible for someone to add a Quit confirmation dialog box to
Mozilla?  It would work something like when one accidentally hits command-Q (on
Mac) on Alt-F4 (on Windows) instead of the keys they meant to hit, they would be
presented with an opportunity to correct their mistake by way of the
confirmation dialog box.  This is most useful on Macs in my honest opinion since
the key command to close a window is command-W and the W and Q keys are next to
one another.  I know that I've been bit with this problem on more than one occasion.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
This looks more like a dupe of bug 52821 to me.
I've been reading <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=39057">bug 39057</A> for the
last few minutes.  It would appear that 39057 originally started on a topic that
is not directly related to this feature request.  However by the time <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=39057#c164">comment #164</A>
was written it dealt with my particular topic.  <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=52821">Bug 52821</A> pertains
to my request through and through but <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=39057">bug 39057</A> did also
morph into it as well.  It's a toss up.

Either way the problem should be addressed.  I mean it's been talked about since
2000!  I could have learned to be a good programmer in that amount of time and
fixed it myself. :-)  <A
HREF="http://bugzilla.mozilla.org/show_bug.cgi?id=52821">Bug 52821</A> gets my vote.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.