Import/Export Profile (Backup/Restore)

RESOLVED INCOMPLETE

Status

()

enhancement
P3
normal
RESOLVED INCOMPLETE
20 years ago
3 months ago

People

(Reporter: BenB, Unassigned)

Tracking

(Blocks 2 bugs, {helpwanted})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

20 years ago
Michael Collette Michael Collette <metrol@earthlink.net> wrote:
> 25. Import and Export functions for an entire profile, or multiple
> profiles.  I know there's a back end way to do this under the User
> folder, but it's probably pretty safe to say that you don't want a
> newbie in there tweaking around with that.  This should be handled at
> the UI level.
>   Along these same lines, this type of functionality would go a long way
> to help with back up and recovery schemes.  I would hope that any Export
> function would also compress the data as much as possible, which would
> make for a reasonable means for storing away.  E-Mail is just too
> critical to not have this kind of function.

Note, that profiles are stored in $HOME on Unix and may be stored by default in
the Documents folder on Windows (not yet decided; dunno about Mac), so they are
backed up together with the other data of the user, if there is a good backup
strategy.
Reporter

Updated

20 years ago
Whiteboard: [HELP WANTED]
Reporter

Updated

20 years ago
Severity: normal → enhancement

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M20

Comment 1

20 years ago
If you've saved the actual data, you can use the -CreateProfile "profile_name
[profile_dir]" switch to create the new profile.  If you then copy the contents
into the profile_dir you will have recovered the profile.  An explicit tool to
handle this is unlikely to get attention in this release.

It shouldn't be hard to create a script or batch file that helps the user
through this.

Updated

20 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 2

20 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.

Updated

20 years ago
Keywords: helpwanted

Updated

20 years ago
Summary: [HELP WANTED] Import/Export Profile → Import/Export Profile
Whiteboard: [HELP WANTED]

Comment 3

19 years ago
Reassigning to myself.
Assignee: selmer → racham
Status: ASSIGNED → NEW

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
This kind of info could just be mentioned in the release note....
Not something that should be put into the application, since backing up a 
profile is just a matter of copying all files under the profile.

Comment 5

19 years ago
Doing a mass reassign to Conrad Carlen.

Conrad is going address all current and upcoming profile manager issues. Please
do not hesitate to involve me in any of the issues.
Assignee: racham → ccarlen
Status: ASSIGNED → NEW
There are plenty of software backup programs with which the user can do this.
This doesn't need to be handled by profile mgr.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
Reporter

Comment 7

19 years ago
Conrad, I disagree. What happens, if I just save the profiles folder, but not
mozreg.dat (and, for any reason, like a system reinstall or move to anotehr
computer, don't have the old mozreg.dat available)? The profile won't be
recognized, right?
The workaround selmer suggested is not something a normal user could do. Backing
up or moving profiles to another computer should be easy. The fact that it is
easy code-wise is even *more* (not less) reason to implement it.

REOPENing, nobody. (It is helpwanted already.) If you think, it *should not* be
implemented, please give a good reason.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Reporter

Comment 8

19 years ago
.
Assignee: ccarlen → nobody
Status: REOPENED → NEW
Target Milestone: M20 → ---
mozreg.dat is not used anymore. If the directory <Application Data>Mozilla was
backed up, it can be restored and used without problem. This directory is in
different places depending on the platform and you would be backing up and
restoring ALL profiles in doing this. Again, why should the profile mgr deal
with this when it is a normal function of data backup?
Reporter

Comment 10

19 years ago
> mozreg.dat is not used anymore.

There is no file, which lists all profiles? How are profiles found (especially
those in custom/external dirs)?

> Again, why should the profile mgr deal
> with this when it is a normal function of data backup?

If nothing else, because it is hard for a normal user to find the profiles dir.
We do the right thing(tm), but Windows usually doesn't (throws the Windows user
profile into the Windows dir).

Updated

19 years ago
Depends on: 66259
>> mozreg.dat is not used anymore.

> There is no file, which lists all profiles? How are profiles found (especially
> those in custom/external dirs)?

mozreg.dat was the old name of the registry file. It's now registry.dat which
lists all profiles and lives in the product profile dir beside "Users50" Before,
there was also mozregistry.dat which was global to all mozilla or embedding
products - bad, that's why it was changed. That was done away with about M17. We
still read that file and move entries into the new registry but since the only
people with profiles made before the time of M17 which have not been moved to
the new place is probably nobody, I think we could get rid of this migration
from mozregistry.dat -> registry.dat. It's just dead legacy code at this point.

Comment 12

19 years ago
Pack-to-Go: XML export/import of all settings

If you need to upgrade your hard disk or start using another computer, moving
all your settings with you to the new environment can be a pain. Mozilla should
support export/import function to save to a file/load from a file all settings
and data Mozilla records, either locally or in servers (LDAP etc.). This
includes bookmarks, address books, mail account settings, cookies etc.

The UI to this function should allow to select what information is exported or
imported. It should be possible to e.g. merge bookmarks by exporting them from
another computer and importing into another Mozilla.

The file format for the exported data should be textual, standards based and be
able to store the aggregate data of any or all of the settings into a single
file. Some XML based format seems an obvious choice.

It's important to be able to store all the settings in a single file to make it
easy to transfer. Having a text based format makes it easy to mail these files
around. Textual, standards based format makes it possible e.g. for the systems
administration to make scripts to automatically generate the right personified
settings for every employee in a company or to otherwise manipulate the
settings. (E.g. we just had to change our news server and being able to export
our ns4.x news data, renumber it and import would have been a real time saver
for us all...)

For some reason, there have been only arguments related to backup of user data
in this bug. I think it misses the point of this feature. There are other, more
important needs for this, as can be seen by some individual efforts trying to
address the same issue for some part of user data. I think it would benefit all
to coordinate this a bit application wide.

Some bugs related:
bug 14096 LDIF import/export to deal with legacy data from/to 4.0x & 4
bug 52045 [FEATURE] Export Address Book - ldif, csv, txt
bug 18247 [FEATURE]We cannot export just a mailing list. The whole PA
bug 52431 Optionally synchronize bookmarks with bookmarks/favorites of
bug 55057 Mozilla should support XBEL -- the XML Bookmark Exchange Lan

Reporter

Comment 13

19 years ago
> It should be possible to e.g. merge bookmarks

This is way over the scope of this bug, as originally intended. This bug is more
about backup/restore (including moving to another computer).

What you are probosing is more like Roaming (there are bugs about it).

> Some XML based format seems an obvious choice.

For the above task, a zip archive is the obvious choice, considering that the
profile (on disk) is mix of all sorts of filetypes - HTML, XML, JS, databases,
large textfiles (e.g. mailboxes) etc..

Comment 14

18 years ago
*** Bug 98562 has been marked as a duplicate of this bug. ***
This bug would also be useful when new profiles have to be created in the sense
of a bugfix. 

In other words, when the fix is "create a new profile", it would be nice to be
able to export the settings/history/bookmarks from one profile and then import
those into another profile (and, in this case, it wouldn't be possible to just
copy the files over to the new profile, since that would defeat the purpose of
creating a fresh profile).
*** Bug 104951 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
Moving Mozilla's applicationdata folder to another system that has the
applicationdata folder on another drive seems to cause problems, You'll have to
hack the prefs.js and the filters file to get everything to work again. The same
is if you want the mozilla userprofile to be stored elsewhere (because the
partition containing your usersettings is tto small or on a networkdrive with a
tight quota)

This feature would be very welcome indeed

Comment 18

18 years ago
*** Bug 124379 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
Is Import/Export mean in this sense:
Export = Backup/Store
Import = Restore

If so, I would humbly suggest a different bug summary (closer to the words on
the RHS), as import/export can imply conversion to/from a foreign format (e.g.
import Microsoft Outlook mail, etc.).

Provided everyone here knows what's going on, it's no big deal, but it might
help people find this bug if that's what they're looking for.
Reporter

Updated

18 years ago
Summary: Import/Export Profile → Import/Export Profile (Backup/Restore)

Comment 20

18 years ago
It's indeed about backup/restore

Comment 21

17 years ago
*** Bug 135954 has been marked as a duplicate of this bug. ***
I'd really like to see the ability to use a network-server location for profile data, that way I could set 
up workstations with a local install of Mozilla and a single fixed network location for the profile.  
With Netscape 4 I could do this, I set the profiles up in U:\Netscape\Users\Default, and each 
user's U:\ drive was different.  Users could log in on any workstation (all are similar in software) 
and have their bookmarks etc.  
> I'd really like to see the ability to use a network-server location for
profile data

I completely agree - though that point goes beyond this bug. See bug 79419 or
bug 31732.

Comment 24

17 years ago
*** Bug 147009 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
It occurred to me why I'm not on the bleeding edge of the mozilla testing
environment: I have no easy way of backing up or reloading all my email
addresses/ filters/ mail boxes etc. I don't want to venture too far away from
what is safe because my data under mozilla is 'not safe', because the
backup/restore interface is nonexistant. I've personally lost my email account
information 4x with moz. I may be a dumb user but then again I know I'm not alone.
Reporter

Comment 26

17 years ago
Compare bug 63389, for mails only.

Comment 27

17 years ago
Re: Comment #12

I would be very happy to see the kind of functionality risto.kankkunen@iki.fi
suggests. I just spend half an hour moving the data of a borked profile to a new
one. While this is doable it is certainly a pain in the ass and not something
the average user wants to do. We definitely need a profile manager that allows
to easily move complete profiles or only parts of them (rules.dat, mails,
passwords etc.). This is surely beyond the scope of this bug but as far as I can
see there is no separate bug for it but only bits and pieces in all kinds of
bugs. Does Ben's current work on roaming profiles cover this or do we need
another bug for this?
Reporter

Comment 28

17 years ago
> Does Ben's current work on roaming profiles cover this or do we need
> another bug for this?

(Bug 124029) Well, I guess that would be a workaround, if it's done, yes, but
more like a shot through the eye into the chest.

Comment 29

17 years ago
Ok, I filed Bug 187564.
Reporter

Comment 30

17 years ago
oh, and roaming can only store small parts of the profile. only single files
(e.g. no mail hierarchies).

Comment 31

17 years ago
*** Bug 192860 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago
*** Bug 85316 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 193567

Updated

17 years ago
*** Bug 187564 has been marked as a duplicate of this bug. ***

Comment 34

16 years ago
Since 1.4 is to be the newest, stable, kill-all branch for a while, doesn't 
anyone think that this bug and the depending/blocking bugs should be given 
some attention?  End user browsers will be based off of this, and it's beyond 
the scope of many end users I've had experience with to dig through their 
hidden Application Data folders to back up their profile, and to name it 
exactly what it was before.  Heck, I've had a bad experience there myself.  
Backed up my profile, formatted my system, only to find that I couldn't for 
the life of me get my old profile to sync up with a newly created profile in 
Moz.  We need some attention on these bugs.

Comment 35

16 years ago
As much as I agree with you about the importance of this bug, these kind of 
posts are pointless. For one, asking for a bug to be fixed, doesn't help at all. 
This bug (and most other open bugs) isn't getting fixed because no one has free 
time to do it, and not because someone is against fixing it. If you want a bug 
fixed, do it yourself, and if you cannot do that, vote for it. Besides voting 
there's nothing normal users like me and you can do. Second, 1.4b is being 
frozen right now, so there is no way this kind of massive redesign will make its 
way into 1.4. This information is available to anyone interested on 
mozillazine.org, so please inform yourself before making such a post. I don't 
want to be rude, but arguing about the importance of a bug doesn't get it fixed.
Amen. I wish would could have the text of comment 35 at the top of every bug
page permanently.

Comment 37

16 years ago
Just trying to lobby for this bug a bit, right or wrong, people need to be 
reminded that this important bug still exists.  The voting system seems pretty 
useless.  Lobbying and useless voting, Bugzilla sounds a lot like the U.S. 
government. :-)

Comment 38

16 years ago
I use Mozilla Mail on Win XP, the version in Mozilla 1.3.1. I have a dual boot
system and ran scan disk on Win 98 (the other OS). It reported an error in my
profile folder and I chose "Fix this error". When I rebooted in Win XP, I found
my profile had disappeared, leaving only my wife's profile. All my folders were
still there, yet the profile manager did not register them. I tried creating a
new profile and moving the folders, but every time I quit Mozilla or swithed
profiles, the new profile I had just created disappeared. I uninstalled then
re-installed but the problem remains. I can no longer create profiles. I might
add the profile that disappeared was originally the default profile, just in
case this makes any difference. I have had to install Mozilla on my Win 98 OS
and have copied the folders from XP and it seems to be working fine but it's a
pain in the **** having to re-boot just to check my mail. If the problem can't
be fixed I might have to start using Outlook Express (gah!). Thanks. Mozilla is
great - keep up the good work.

Comment 39

16 years ago
*** Bug 209393 has been marked as a duplicate of this bug. ***
*** Bug 209490 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
I'm not sure if bug 209490 is a duplicate of this or not.

This would be a *workaround* for bug 209490, but the real bug of 209490 is
that on Windows XP, a users's home dir is set by the environment variable
%USERPROFILE% which in turn is set from the system variable "%SYSTEMDRIVE%.

If I move my SYSTEMDRIVE from C: to D:, mozilla isn't using the Unix equivalent
of $HOME to store the profile in.

I.E. still works -- why? because it uses %USERPROFILE%/<dirname> for cookies
tmp files, etc.

Mozilla breaks because it uses hard coded values under Windows.  

This would seem to be a BUG -- not a feature request of a profile 
import/export -- or am I missing something?

-linda

Comment 42

16 years ago
What is the status of this - Nobody's working on this ??

There is today (Mozilla 1.4) NO easy way to Backup and Restore Profiles !

Situation:
You install Mozi (Mozilla 1.4) on an NEW PC. Now you will
Restore ALL Userprofiles from the OLD PC machine or from a Backup path!

There is no way - you have do add all Profiles again enter all Accounts, IMAP,
and perhaps you can copy the email-Files in the folder, and move Adressbooks.
All ways are difficult and need many time and have many errors.

The easy way is today, to import ALL in MS-Outlook and export them to the new
Mozilla-Profile on an other computer. *grrrr*

Please Support a button in Profilmanager: Import Profiles !!!
(Import Profiles, All Settings, ALL Email-Accounts, AdressBook and all
News-Account from Backup Path or other PC)

-Roland-

Comment 43

16 years ago
My thought (from a post on MozillaZine) was this:

Ultimately I think it would be nice if we had a GUI that would ask us where we
wanted to back our profile up to (or restore from) and display a list of the
stand-alone products that are present to include for backup. For example, I
could check Browser (cookies, bookmarks, etc.), Mail, and Calendar, but leave
Composer and Addressbook unchecked.

That sort of system could provide a common thread for everything built upon the
Gecko engine to "sing together" through.
*** Bug 214104 has been marked as a duplicate of this bug. ***

Comment 45

16 years ago
*** Bug 220236 has been marked as a duplicate of this bug. ***

Comment 46

16 years ago
Just heard about this project on MozillaZine: 
Mozilla Backup - http://backup.jasnapaka.com/

Perhaps it could be integrated into Mozilla?

Comment 47

16 years ago
This is extremely curious!  I see more than 10,000 requests for this
export/import feature documented on the NetScape/Mozilla websites, forums and 
and BugZilla, etc. And..  Would you believe STARTING IN 1999!  

I can not believe that the developers have left this important feature hanging
for FOUR YEARS when there was a pretty good working model in Netscape 4.7x.

Can someone explain how this happened?  Is it once again that fixing often
requested and useful features just is not as exciting as developing something
strange and new.  Please let us all know how such an important feature for an
email system could be left unimplemented for FOUR YEARS!  Mozilla cannot even
import its own files from a windows 98 Mozilla 1.5 to a Windows 2000 upgrade!
With regards to comment #47, the reason this hasn't been implemented is because
no-one has taken it on. If you don't have a clear understanding of the nature of
open-source development, and the difference between Mozilla and Netscape
Communicator 4.x, I suggest you read up on it before adding comments in bugzilla.

Comment 49

16 years ago
As things stand now,  it is "virtually" impossible for most people to upgrade a
computer from Windows 98 to Windows 2000 or XP and carry along their old Mozilla
User Profile.  This is a situation QUITE UNIQUE to Mozilla! Other products work
very hard to AT LEAST assure UPWARD compatibility.

Since Mozilla developers "have not taken an interest" in the plight of tens of
thousands of Mozilla users who need from one time to another to "move" profile
data from one version of Mozilla to another or to one platform to another, 
perhaps there is another solution.  Perhaps someone knowledgable about database
manipulation could design a stand alone solution that would take Mozilla
profiles and translate them to/from Outlook Express format.  There are many
solutions available for going from OE to many other mail clients (EXCEPT
MOZILLA).  If there was a way to go to/from OE with a Mozilla Profile,  it would
be a two step process to go to/from other systems but you could get there. 

Comment 52

16 years ago
Hi Gbush,
Thanks.. I just finished DOING that on TWO Windows 98 machines upgrading to
Windows 2000 and XP and using the referenced procedure.  THAT is why I said it
was "virtually" impossible for ordinary folks to do the migration.  If anyone
things it is a trivial or quick procedure give it a try.  

I guess I could figure out a way to "browse" the Internet using my telnet
client,  but I don't wanna!  For that reason I use special purpose programs
called "browsers".  Similarly,  I like to use special purpose programs called
"profile migration programs" to migrate from OE to Mozilla or from Agent to OE
and etc.  Too bad Mozilla has allowed tens of thousands of people (according to
archives on the internet about this topic) to use THOUSANDS of manhours to do
this migration by the above linked tedius and time consuming manual way when a
small fraction of this manhour waste would produce some kind of workable
automated conversion routine.   And we wonder why Mozilla (though it has
TREMENDOUS POTENTIAL) has not caught on.  The reason of course is the lack of
attention to ESSENTIAL functions in favor of making "neat new features".  Not
atypical of what is to be expected when a major product development program is
run by a committee without a manager who understands what is necessary for the
ultimate market accepability of a product.  We have all seen this many times (if
we are old enough!).

I only wish I was competent to do it myself!
*** Bug 222535 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 19454

Comment 54

16 years ago
Mozilla Backup is a utility for creating backup of Mozilla, Mozilla Firebird and
Mozilla Thunderbird profiles.

Download program include source code.
http://backup.jasnapaka.com

Include it !
-Roland-

Updated

16 years ago
No longer blocks: 19454

Comment 55

16 years ago
I suggest that the CURRENT way of storing profiles is an abomination (at least
in Windows 2000 and XP).  Lots of things cause  MS Operating Systems to create a
new profile that have NOTHING to do with a fault in Mozilla (which Mozilla
Faults also can create a new profile and lose your data) causing a profile to
get "detatched" from Mozilla.  Lately,  in Mozilla 1.5 it seems mostly Mozilla
crashes are at fault for these problems.

In both cases,  Mozilla generates a brand NEW PROFILE and there is NO WAY for a
causal user to get his data back.  YES>> I know about the intricate, complex,
and error prone tedious procedures noted above and they are prime evidence of
the need for a SIMPLE USER ORIENTED way to recover a "lost" profile or
components thereof.  

What is needed is a way to "point" to some selected *.slt file and have it
checked as valid and then imported into some newly named profile which Mozilla
can access.  This SEEMS like a quick and simple fix.  It would also be extremely
nice to be able to import individual mail files, address books, and bookmark
files into an existing profile from some "orphaned" *.slt file.

I have just removed two Mozilla users to IE6/OutLook Express (which the users do
not like) because (at least) there is an easy way for them to back up their
email files.  (It is almost impossible to believe that  Mozilla has NO WAY to
backup and recover a user's profile!!!)

The only way that I have discovered to recover from these all-to-frequent
Mozilla mail crashes where the profile connectivity is "lost" is to run GOBACK
or similar and have the user GOBACK to some earlier time where Mozilla is
working.  This seems to work fine,  but it is surely a severe problem when this
is the ONLY solution for the vast majority of users.

Programmers sometimes forget:  98% of the people who USE software are NOT
PROGRAMMERS,  do not want to learn to program and are extremely uncomfortable
with complex data recovery proceedures such as Mozilla requires to recover lost
profile data.  It is almost incredible to me (who used to manage embedded system
development programs) that Mozilla management would leave such a "user abusive"
flaw as no profile import/export ability in Mozilla for over THREE YEARS after
the user complaints started.  (See the archives!).  I guess this is what you
must live with when a project has no central guidance dedicated to making users
comfortable with a product.
Hi,

I suggest to add a feature to Mozilla / Firebird that allows to create backups
of files such as bookmarks.html, Personal toolbar, mail prefs, news prefs, etc.

How about adding a menu entry to the "Edit / Preferences..." menu underneath the
"Naviagtor" branch called "Settings backup"?

This should contain tick boxes of what somebody wants to backup, to where and
how often (time interval) this should happen. Also a restore feature should be
introduced with a selection option what and which backup should be restored.

This may solve some of the issues where an OS freezes or crashes unrecoverably.

--Christian

Comment 57

15 years ago
*** Bug 240915 has been marked as a duplicate of this bug. ***
*** Bug 253425 has been marked as a duplicate of this bug. ***

Comment 59

15 years ago
MozBack (http://backup.jasnapaka.com/) can create backups of Mozilla, Mozilla 
Firefox, Mozilla Thunderbird and Netscape profiles. It allows you to backup
mail, favorites, contacts, etc.

Maybe that one can be integrated into Mozilla.
*** Bug 278351 has been marked as a duplicate of this bug. ***

Comment 61

15 years ago
It is really unbelievable that this profile backup problem has been talked about
now for FIVE YEARS and yet it has never risen to a priority position high enough
to be fixed.  I think this shows that Mozilla needs an overall management scheme
with users able to VOTE important (to them) issues into a priority position high
enough to get problems fixed.  

Updated

14 years ago
Blocks: majorbugs

Updated

14 years ago
No longer blocks: majorbugs

Comment 62

14 years ago
*** Bug 301122 has been marked as a duplicate of this bug. ***

Comment 63

14 years ago
A pure text export (perhaps XML) of the browser setup and version (minus bookmarks,form info) would be very useful if you have to manage issues for an organization.

Case in point:  an application is working perfectly for everyone at Site X, but the folks at Site Y have an issue.  A natural assumption might be that the folks at Site Y have set up their browsers differently.  How to find this out?

Export the security setup from Mozilla from a browser at each location and run a diff.

Updated

13 years ago
Blocks: 249801

Comment 64

13 years ago
*** Bug 259787 has been marked as a duplicate of this bug. ***
*** Bug 363171 has been marked as a duplicate of this bug. ***

Comment 66

12 years ago
Here's my vote for a proper Export feature, or perhaps Backup. Don't forget the target audience; it's not just for fellow Hackers. A simple Backup Profile, for instance, could create a Zip archive in a location of your choosing, and Restore Backup (eg after moving to a new computer, or HD crash) simply unzip to Profile (maybe with a Merge capability).
Export is useful for moving to other Email apps, say Apple's Mail (never used it, so it may be able to import from RB just fine).
Import is another bug report; it also needs to support Outlook PST files where you have the backups and archives, but not Outlook installed.
Duplicate of this bug: 389041

Comment 68

12 years ago
Hi, 

I want to specify a location on a different hard drive as my "Data Position" for my email profile, address book and mail folders and mail data so if my C: drive crashes I always have 100% of my email system.  The Bookmarks.html file should also be set on that drive to save those setting too.  

I want to just click on a BackUp button, point to the drive to backup onto and
specify the filename (yyyymmdd-Thunderbird.XXX) and have the entire system in a
recoverable fashion on a different hard drive than C:  

Expected Results:  
I want to click on a BackUp button, point to the drive to backup onto and
specify the filename (yyyymmdd-Thunderbird.XXX) and have the entire system in a
simple recoverable fashion on my D: drive NOT my C: drive.  

This should be an important feature to all software products.

I perform a bit-copy backup of my C: drive once a month ... this covers my programs and Windows settings etc... but my daily work I keep on a D: drive and my email profile, email, address book and bookmarks should be available there too always 100% safe from a C: drive crash.  
Reporter

Comment 69

12 years ago
FWIW, you can specify a different location where your profile shall be stored (main version, not backup). Read/search on profile creation commandline arguments.

Comment 70

12 years ago
(In reply to comment #69)
> FWIW, you can specify a different location where your profile shall be stored
> (main version, not backup). Read/search on profile creation commandline
> arguments.
> 

Hi, You're missing the point of the bug report ...  

99% of users do not want to have to write scripts to run applications ... but if a remote profile and data can be easily created by users they might save themselves from headaches of lost emails, address' and bookmarks etc... 

Having a "BackUp" button and menu bar item also allows for easy end-user access to saving their emails, address' etc... 

We want to click on a BackUp button, point to the drive to backup onto and
specify the filename (yyyymmdd-Thunderbird.XXX) and have the entire system in a
simple recoverable fashion on my D: drive NOT my C: drive.  

These two features should be available in all software products ... even something as basic as the profile and data for your OS (my idea of a Personality Module circa 1985)! 


Duplicate of this bug: 395859

Comment 72

11 years ago
I have just gone through the process of moving my profile from XP to Vista. Just creating a new profile and copying the contents of the old profile on the old machine to the new one does not work, or at least it didn't work when I did it. The files move, the paths appear to be correct, and the profile name appears correctly in the switcher extension, but no files appear in Thunderbird. A user forum suggested I install an import/export plug-in and then import the mail folders from the profile into itself. This worked, but it loses all the account information and file structure, and doesn't import filters or address books. I am still working on recreating everything. It will take many hours. <insert="obvious rant"> At minimum, this problem should be fully disclosed to potential Thunderbird users at the outset. I would never have used Thunderbird had I known that backup and restore was so difficult.

QA Contact: agracebush → profile-manager-backend

Updated

10 years ago
Duplicate of this bug: 522869
Duplicate of this bug: 552671
Duplicate of this bug: 552422

Updated

5 years ago
Duplicate of this bug: 1120206
This adds a button to the Create Profile Wizard that causes the profile to be restored given either a prefs.js file or a .zip (which is assumed to contain a profile).
Attachment #8567177 - Flags: feedback?(ben.bucksch)

Comment 78

4 years ago
In 2007 the then new profile manager Beta had a competent profile backup and restore.  But that never got off the ground and the profile manager remained in core. Could that work be ported? 

Users expect a simple method of transferring their profile machine to machine. Command line switches went out with DOS.  Most of the refugees to Linux a GUI only people. So updating the existing profile manager is of no use unless it is made accessible to the masses. 

Most expect to use the import and export entries on the Thunderbird/Sea Monkey tools menu to complete the task.  However I see the Firefox support folk also have issues as people are now relying on Firefox sync for this and failing.
Could the profile manager be made more accessible from in app with a menu option to trigger the profile manger on next start? ala the profile switch add-on.
The easiest way to get to your profile folder to back it up is via about:support (Help > Troubleshooting Information) and clicking the button in the top section to open the profile folder.
(In reply to Matt from comment #78)
> In 2007 the then new profile manager Beta had a competent profile backup and
> restore.  But that never got off the ground and the profile manager remained
> in core. Could that work be ported? 
I had no idea that work existed. Do you know where I can find it?
Reporter

Comment 82

3 years ago
This is a feature desperately needed by end users, independent of the implementation.
Thus, moving out of Profile:Backend, just to rescue it from the move to graveyard.
No longer blocks: 1243899
Component: Profile: BackEnd → Preferences: Backend

Comment 83

3 years ago
The suggestions made here that profile information is readily backed up/restored by copying/backing up user directories *may* work if you are staying within the same OS/  However, if you are moving MSWin->Linux (or, even more troublesome, from Linux->MSWindows) then copying the profile.ini, prefs.js, etc is not going to work.  I have tried this, and I have even tried editing a prefs.js file from a Linux install to use the file/dir paths for the MSWin setup.  Quite simply, this fails miserably.  there are way too many hidden/obfuscated/undocumented configuration locations on MSWin.
   
Quite simply you need to have an export utility which will copy over user/password info, server names, extensions, etc.  When you have 6 or 8 different emails to deal with, along with various newsgroups and such, having to write out EACH one to be manually entered, it becomes a severe problem.
As a feature request, this is not on the radar for the next 6-12 months, so I'm going to close this out because keeping RFEs open isn't useful. At this point we would not accept a patch for this.
Status: NEW → RESOLVED
Closed: 19 years ago3 years ago
Resolution: --- → INCOMPLETE

Updated

3 years ago
Attachment #8567177 - Flags: feedback?(ben.bucksch)

Comment 85

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #84)
Can you explain in what sense closed RFEs are better, when the feature is still highly desirable for many? Also, why a patch is now unacceptable in principle?
... this is, after all, a bug with 78 people on the CC list, I think a somewhat longer comment is fitting when closing such a bug.

Comment 86

3 years ago
Seconded.
The decision here is that we don't have the resources (engineering, product, QA, maintenance) to do this feature well, compared to the many other features we could work on. So we won't accept patches for this feature. Rather than leave the bug open, our bug triage policy is to close this kind of thing out.

Comment 88

3 years ago
Hold on.  The team was able to store this information into a Cloud format, so it can be used across machines, but you can't figure out how to splat it into a text file on demand?

Comment 89

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #87)
> The decision here is that we don't have the resources (engineering, product,
> QA, maintenance) to do this feature well, compared to the many other
> features we could work on. So we won't accept patches for this feature.
> Rather than leave the bug open, our bug triage policy is to close this kind
> of thing out.

That's seems a rather short sighted policy. It throws good ideas into the trash (nobody is someday going to go through thousands of "incomplete" or "wontfix" bugs). What if  Leonardo da Vinci had said: " Hmm, I invented this cool flying helicopter thingy, but I don't have the resources to build this, so I'll just throw my drawings into the trash. How about a "status" "Future" (or similar)?

Comment 90

3 months ago

As I mentioned years ago, the issue becomes more of a problem when moving between OSes. Now that I'm thinking further on this, there could also be other scenarios, such as a corporate account (help, sales queries, etc.) that may be moved from one user to another, but only that one particular account is being moved. Or a company, ISP, etc could have pre-defined configuration files which a new user could simply import.

Entirely possible (likely even) that this would be a utility separate from the main application. Maybe even something tossed together in Python, Perl, or whatever the scripted language of the week happens to be (well, the latter is probably a BAD idea). In which case it might simply require some clear, concise documentation on the prefs.js file, enough that a scripting wizard could whip something together. In which case I'm guessing Python as that's probably the one readily available on a wider range of platforms.

You need to log in before you can comment on or make changes to this bug.