Table on the right gets clipped

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: deepakgoel, Assigned: dcone)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Layout doesn't work properly. Right hand table gets clipped even when the table
can be accomodated.

Comment 1

19 years ago
The centre part of this page resizes as the page is resized horizontally,
keeping the right-hand table partly clipped at all times.  It is possible that
there is bad HTML here - did not check for that tonight.

Tested with: 1999-12-25-08-M13 nightly bianry on Windows NT 4.0sp3

Comment 2

19 years ago
Confirming bug with build 1999122708 on Windows 98 SE. Saving the page locally,
adding <base href="http://www.javasoft.com/"> and loading it with "file:"
or from a local server (MS IIS) "http://localhost/" makes the page look fine.
The bug is only triggered when loading directly from http://www.javasoft.com

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

19 years ago
I don't see a problem with today's build. The table doesn't center itself, and I
don't see the right edge of the table get clipped

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 4

19 years ago
This problem is not occuring on the Linux or Windows 98 builds (2000010308) but
is on the Mac build (2000010308). I have attached a screenshot of the problem
that is only occuring on Mac.

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 5

19 years ago
Created attachment 3934 [details]
clipped table on mac browser

Updated

19 years ago
Assignee: troy → petersen
Status: REOPENED → NEW

Comment 6

19 years ago
If it only happens on the Mac then it probably isn't a layout bug.

I don't know what to do with this bug since I can't reproduce it (a screenshot
doesn't do me much good). Does it happen both with gfx scrolbars enabled and
with native scrollbars?

Comment 7

19 years ago
This problem on the Mac is not happening with native scrollbars just when gfx
scrollbars is enabled. Both Win and Linux versions have gfx scrollbars enabled
but are rendering the table correctly.

Comment 8

19 years ago
Created attachment 4276 [details]
clipped table on Win98, native and GFX scrollbars

Comment 9

19 years ago
This bug is not Mac only. It occurs with build 2000011314 on Windows 98 SE,
both with GFX scrollbars and with native scrollbars. See screenshot above.
The right table is clipped and resizing the window does not help.
Reloading the page makes it lay out correctly though. I noticed that Native/GFX
have different behaviour when narrowing the width of the window:
Native:
  When the right column touches the center one a horizontal scrollbar pops up.
  (The right table is still clipped though when scrolling to its end position.)
GFX:
  When the right column touches the center one no scrollbar appears and
  narrowing the width even more makes the right col. overlap the center col.

I tried again to make a smaller testcase but failed. I think it could be a
matter of how fast different parts of the page loads. I am using a slow modem
(28.8) and this bug is 100% repeatable for me on Windows 98 SE.

Comment 10

19 years ago
Yes, I'm able to reproduce this problem on this page. Right aligned table is 
cropped. This is problem doesn't occur for me on Windows 98 (2000012609) but 
happens on Mac (2000012612).
Assignee: petersen → karnaze

Comment 11

19 years ago
Error does not occur on Build 2000012516 Windows NT SP4

Comment 12

19 years ago
I'm not seeing the problem either on WinNT. Don, can you take a look on the Mac.
Assignee: karnaze → dcone
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 13

19 years ago
It works for me.. but the page has changed also.  

Updated

19 years ago
Keywords: verifyme

Comment 14

19 years ago
Verified
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.