Fedora download page does not repaint properly when scrolling

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: jones.peter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6b) Gecko/20031126
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.6b) Gecko/20031126

I am running Build 2003112608.

My OS is really WinME. When I attempt to access the above link, the page fails
to scroll properly. This may be a problem with large pages, not just the Fedora
site. The text containing the file name stops scrolling around the P's, and the
line spacing causes the lines to overlap. There is often a delay between moving
the scrollbars and the text moving, and the text fails to follow the scrollbars
to the bottom.


Reproducible: Always

Steps to Reproduce:
1. Access above URL in Navigator
2. Attempt to scroll to the bottom
3.

Actual Results:  
Text doesn't scroll all the way.

Expected Results:  
Text should scroll normally.

WinME operating system.
(Reporter)

Updated

15 years ago
Summary: page doesn't scroll properly → Above page doesn't scroll properly

Comment 1

15 years ago
WFM on current Linux CVS trunk build.

How are you trying to scroll?

I tried dragging the scroll bar, arrow keys, paging with PageDown, paging with
space bar - all of them worked as expected.

When you are as far down the page as it will let you: does the scroll bar look
like there was still more data on the page but it won't let you go there, or is
the scroll bar all the way down at the bottom?

When you hit Ctrl+U (view page source), is the source of the page complete?

Does shift+reload'ign change anything? Is it always the same position on the
page where your page seems to end, or is it different every time you shift+reload?

Are you behind a proxy, or accessing the 'Net directly?

Comment 2

15 years ago
Created attachment 136419 [details]
Example of display fault

Comment 3

15 years ago
Can see same problem, Win2k, 2003111415.  Page appears to be fully loaded, as at
the bottom I have the copyright text, etc.  Also can see that Mozilla is picking
up links that I can't actually see.  The last line that renders correctly is
"perl-HTML-Parser-3.26-18.src.rpm 28-Oct-2003 17:45    75k  "

I will attach a grab of the display, althought it appears to be a bit variable.
 If I scroll the page, I get odd lines, whereas if I switch aqay and back I get
a "ghost" of the previous window.

Comment 4

15 years ago
it was hanging with build < 20031116, see bug 225848.

Comment 5

15 years ago
I´ve seen this behaviour in 
Bug 189136 upon scrolling down the display gets corrupted.

There you had a huge table, showing double scrollbars. After scrolling down
about two thirds of the file a table row got repeated again and again.
If you switched to another tab and back, the area filled with the repeated row
was still showing the content of the other tab.
I´ll attach a 36 kb screenshot made here, and there are screenshots in the other
bug. Some comments in the other bug are misleading.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Created attachment 136421 [details]
upper part fedora, lower part bugzilla (36 kb screenshot)

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031126

While loading the page mozilla was reacting very slow on a 333 MHz Celeron,
scrolling in other tabs was also affected.
Switching from the Fedora tab to the bugzilla tab of this bug, and back, gave
this screenshot.

Comment 7

15 years ago
http://validator.w3.org was missing a charset, one or two others,
and more than 900 bugs: image isn´t allowed here.

http://selfhtml.teamone.de/html/referenz/elemente.htm#pre
doesn´t list <image> as allowed inside <pre>

So it seems this bug could be resolved as INVALID, but I´m not a HTML guru.


I made a copy using Mozilla 1.5, and it also took minutes to load locally,
but it loaded completely, maybe, because it was from a fresh started browser, no
memory used for other tabs beside the one holding the bug.

Filesize is only 222 kb.

excerpt from the source, replaced parts with IMAGE, URL, NAME for shortening:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

...

<pre><img width="20" height="22" alt="     " src="IMAGE.gif"> Name             
               Last modified       Size  
<hr>
<img width="20" height="22" alt="[DIR]" src="IMAGE.png"> <a href="URL">NAME</a>
                27-Nov-2003 06:22      -  
<img width="20" height="22" alt="[   ]" src="IMAGE.png"> <a href="URL">NAME</a>
       28-Oct-2003 18:03   1.8M  
<img width="20" height="22" alt="[   ]" src="IMAGE.png"> 

....

<img width="20" height="22" alt="[   ]" src="IMAGE.png"> <a href="URL">NAME</a>
           28-Oct-2003 16:59   1.7M  
</pre><hr>

  </div>

Comment 8

15 years ago
After removing the <pre> tags, and inserting the encoding, a local copy of the
page validated. It also was loading essentially faster.
Of course I didn´t insert 900 <br> tags.

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Tech Evagelism? or Invalid?
(Reporter)

Comment 9

15 years ago
Responses to Christian's questions

WFM on current Linux 2003112506, but more sluggish than the mozilla-1.4.1-18
from Redhat.

Back in WinME:
Tried all methods of scrolling mentioned. Scroll bar goes all the way to bottom,
but page of text stops in the p's. I also get overlapping lines of text as
illustrated in the Example of display fault attachment.

Page source is complete.

Saved a page by going to parent directory, then Save Link As. File saves, and
can be displayed completely from the local copy.

Didn't try Shift+reload. Reload doesn't seem to chane anything.

I am accessing the Net directly.

Updated

15 years ago
OS: Windows 98 → All
Hardware: PC → All
Summary: Above page doesn't scroll properly → Fedora download page does not repaint properly when scrolling

Comment 10

15 years ago
worksforme with windows Mozilla 2004020308
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.