random channels have a blank screen after a while

RESOLVED WORKSFORME

Status

Other Applications
ChatZilla
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Konrad, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030

Yesterday I installed Mozilla 1.6a with ChatZilla 0.9.45.
Most times I´m in gamesnet - connecting and joining with a script, which worked
well with Chatzilla 0.9.42
Since the update after several hours sometimes channels become blank. I can type
and people can read me, but I don´t see anything.
The channel name is becoming blue or green, likely as usual if there are status
posts or people chatting.
First I tried to clear the Tab or change the Color Scheme, but didn´t help. BTW
it would be nice to reinvent the Clear Tab command in right mouse click menue
and add the copy command.
Most times its fixed if I leave - or aks some1 to kick me - and join again, but
not always or it does happen again.
If I don´t do anything the chan remains blank, did wait around 1 hour.


Reproducible: Sometimes

Steps to Reproduce:
1. Join gamesnet
2. Join some channels
3. Sometimes talk in chans and queries
4. After several hours look if all chans still work
Actual Results:  
1 or 2 of the usual 8 are blank


Expected Results:  
Chatzilla should display status and text lines
(Reporter)

Comment 1

14 years ago
meanwhile I installed ChatZilla 0.9.48

some1 in chatzilla irc chan recommended said to try /sync-output when it happens

just to see what it does I tried this command on one chan (gamesnet #ddw) and
the result was the chan went blank
then I tried it in other chans, but it just said "undefined"

Javascript Console shows 9 errors:

Error: bgColor has no properties
Source File: chrome://chatzilla/content/static.js
Line: 653

its : function mircChangeColor (colorInfo, containerTag, data)
line : if (bgColor.length == 1)
Summary: random channels have an blank screen after a while → random channels have a blank screen after a while

Comment 2

14 years ago
I experienced the same thing only when connecting to #linux-kernel on freenode. 
It may have something todo with some channels re-directing?

I am uncertain on what is happening. 

btw: i am using 	Chatzilla 0.9.48 [Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.5b) Gecko/20030917] on WinXP sp1

- Mick

Comment 3

14 years ago
Could the reporter (and anyone else seeing this) please try 0.9.54c, or a later
version, and see if this is still happening (0.9.54c - 0.9.54f include a fix for
bug 227402, which may be related). You can get these newer versions from
http://www.hacksrus.com/~ginda/chatzilla/.
(Reporter)

Comment 4

14 years ago
Running Mozilla 1.6b with Chatzilla 0.9.54 the 3rd day without problems.
(Reporter)

Comment 5

14 years ago
Installed 1.6 and Chatzilla 0.9.56 yesterday, seems still ok

a similiar problem I have since long, sometimes an empty user list in some of
the chans
to sort by mode, show mode as symbol and temp. change to working chans usually
does fix it

Comment 6

14 years ago
OS/2 1.7a & 0.9.59.

I'm not sure how random yet. I autojoin 6 moznet channels. #mozillazine is
usually the first to go. #chatzilla normally goes second. After a while I twice
lost also #mozilla, once before losing #mozillazine. All this after less than 10
minutes with CZ open each time. Title/topic div and nick pane remain visible.
Moving the mouse changes the statusbar, so the content is there, just not visible.

/sync-output does nothing apparent to me. /testdisplay jiggles the scrollbar
around as the content invisibly loads, but produces no output window impact.

My userChrome.css contains (among other things) the following:

.view-button[viewKey="4"], .view-button[viewKey="8"] {margin-left: 0 !important;}

#chatzilla-window #tabpanels-contents-box { direction: rtl; }
#chatzilla-window #tabpanels-contents-box > * { direction: ltr; }
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 7

14 years ago
I haven't seen this in a very long time.

Comment 8

14 years ago
Is this bug still valid? I also haven't seen this in a LONG time.

Comment 9

14 years ago
Unless the reporter, or anyone else, has seen this recently with a current
(0.9.64g or 0.9.65) version of ChatZilla, we can probably mark this WFM (though
I might know what fixed it).
Product: Core → Other Applications

Comment 10

13 years ago
Since I can't remember what the heck I meant in comment 9, and unless anyone can
report this with current (0.9.67) versions of ChatZilla, I'm marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.