If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Print Preview Error (Previewing During Page Rendering/No Printer Installed) Shows Print Preview Toolbar

RESOLVED FIXED in Firefox1.0

Status

()

Firefox
Toolbars and Customization
P2
normal
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Jason Barnabe (np), Assigned: janv)

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0
x86
All
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

30.43 KB, image/jpeg
Details
fix
641 bytes, patch
Ben Goodger (use ben at mozilla dot org for email)
: review+
Ben Goodger (use ben at mozilla dot org for email)
: superreview+
Ben Goodger (use ben at mozilla dot org for email)
: approval-aviary+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
If you print preview a page while it is rendering, it gives the "The browser
cannot print preview right now" message, but then shows the print preview
toolbar. Pressing Close closes the tab toolbar.

Steps to reproduce:
1. Go to a page that takes a bit to render, such as
http://bugzilla.mozilla.org/buglist.cgi?query_format=&short_desc_type=allwordssubstr&short_desc=&product=Browser&component=Layout&component=Layout%3A+Block+%26+Inline&component=Layout%3A+Floats&component=Layout%3A+Fonts+and+Text&component=Layout%3A+Form+Controls&component=Layout%3A+HTML+Frames&component=Layout%3A+R+%26+A+Pos&component=Layout%3A+Tables&component=Layout%3A+View+Rendering&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=nowords&keywords=testcase&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=REOPENED&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&remaction=run&namedcmd=Browser+bugs&order=Reuse+same+sort+as+last+time&field0-0-0=cc&type0-0-0=notequals&value0-0-0=jbird3000%40hotmail.com&field0-1-0=longdesc&type0-1-0=notequals&value0-1-0=jbird3000%40hotmail.com
2. While it is rendering, print preview.
3. Press OK on the message that comes up.

Actual results:
Shows print preview toolbar, but does not enter print preview

Expected results:
Don't show print preview toolbar

Comment 1

14 years ago
Confirmed: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.6b) Gecko/20031203
Firebird/0.7+ 
(but I don't have permission to change the status from unconfirmed).

The Print Preview toolbars 'Close' button closes the tab toolbar, but not the
Print Preview toolbar. If you go File --> New Tab, the tab toolbar reappears and
functions as normal, but disappears again if you click the Print Preview Close
button once more. If you go to File --> Print Preview once the page is rendered,
the preview is shown, and the Close button then works as it should.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
*** Bug 229026 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
Confirmed in 20040102 Windows XP/SP1.

I came across this under slightly different circumstances: I don't have a
printer driver installed.  When I hit Print Preview, I get "An unknown error
occurred while printing."  Everything else seems to match this report: the
toolbar appears, clicking Close makes the tabs disappear.
(Reporter)

Comment 4

14 years ago
*** Bug 230796 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

14 years ago
Summary: Print Preview During Page Rendering Shows Print Preview Toolbar After Showing "The Browser Cannot Print Preview Right Now" Message → Print Preview Error (Previewing During Page Rendering/No Printer Installed) Shows Print Preview Toolbar

Updated

14 years ago
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040128 Firebird/0.8.0+

I get following error messages within the JS-Console:

  Error: uncaught exception: [Exception... "Component returned failure code: 
  0x80004005 (NS_ERROR_FAILURE) [nsIWebBrowserPrint.printPreviewNumPages]"
  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
  chrome://global/content/printPreviewBindings.xml :: onxblconstructor :: line
  123"  data: no]

  Error: uncaught exception: [Exception... "Component returned failure code:
  0x80004005 (NS_ERROR_FAILURE) [nsIWebBrowserPrint.exitPrintPreview]"
  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
  chrome://global/content/printUtils.js :: anonymous :: line 202"  data: no]
OS: Windows XP → All

Comment 6

14 years ago
*** Bug 227052 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
For me, on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040129 Firebird/0.7+, pressing Close button doesn't close the preview
toolbar giving the second JS error in comment #5.

Comment 8

14 years ago
Created attachment 141464 [details]
Print-Prewiev toolbar where it shouldn't be

I can confirm this bug with Firefox 0.8
Screenshot added.
(Reporter)

Updated

14 years ago
Flags: blocking1.0?
Flags: blocking1.0? → blocking1.0+

Comment 9

14 years ago
*** Bug 243769 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
*** Bug 239941 has been marked as a duplicate of this bug. ***
Assignee: hyatt → bugs
Priority: -- → P2
Target Milestone: --- → Firefox1.0

Comment 11

13 years ago
*** Bug 248041 has been marked as a duplicate of this bug. ***
Assignee: bugs → sspitzer
Flags: blocking-aviary1.0RC1+

Comment 12

13 years ago
I can confirm with Firefox 0.9.1.

Comment 13

13 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2 

But can anyone confirm it the bar is NOT supposed to show up at all or at a
certain command?

Comment 14

13 years ago
*** Bug 251208 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
I got this too on Linux:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Kinda freaky... thought I lost all my tabs, but opening a new tab redisplays the
tab bar as mentioned up above.
Assignee: sspitzer → varga
(Assignee)

Comment 16

13 years ago
Created attachment 155015 [details] [diff] [review]
fix
(Assignee)

Updated

13 years ago
Attachment #155015 - Flags: superreview?(bugs)
Attachment #155015 - Flags: review?(bugs)
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-
Flags: blocking-aviary1.0PR- → blocking-aviary1.0PR+
Comment on attachment 155015 [details] [diff] [review]
fix

r+sr+a=ben@mozilla.org
Attachment #155015 - Flags: superreview?(bugs)
Attachment #155015 - Flags: superreview+
Attachment #155015 - Flags: review?(bugs)
Attachment #155015 - Flags: review+
Attachment #155015 - Flags: approval-aviary+
(Assignee)

Comment 18

13 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 19

13 years ago
*** Bug 255822 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
*** Bug 257927 has been marked as a duplicate of this bug. ***

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.