Cursor left/right, Pos1 and End keys don't work in text input fields

RESOLVED DUPLICATE of bug 228646

Status

()

RESOLVED DUPLICATE of bug 228646
15 years ago
7 years ago

People

(Reporter: mozilla-06, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20030729
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031126

Sometimes, the caret won't react to the Cursor left/right, Pos1 and End keys in
text input fields. Once this happens, every text input field in every Mozilla
browser window is affected. After a restart, everything is ok again.

I still haven't found a way to reliably reproduce this - it happens more or less
at random.

Reproducible: Sometimes

Steps to Reproduce:
1. Open URL.
2. Place caret in the bug summary field.
3. Type a few characters, delete a few characters (works).
4. Press Cursor left/right, Pos1, End.

Actual Results:  
The caret doesn't move.

Expected Results:  
The caret should move (1 left/right, to the beginning of the line, to the end ...).

This doesn't happen very often, and I still don't know what triggers this bug.
(Reporter)

Comment 1

15 years ago
I've just been hit by this bug. In addition, I now have two carets: one in the
URL bar and one in the text input field (or, in another case, the caret in a
text input field stayed there although I marked some text on the page).

I don't know if these two issues are really related, but it looks like a general
focus problem.

Typing in the text input fields (and deleting text) works fine, though. Just not
the cursor keys.
(Reporter)

Comment 2

15 years ago
This bug seems to disappear even without restarting Mozilla - I just closed a
few tabs and switched between Browser and MailNews a few times.
(Reporter)

Comment 3

15 years ago
These are my build options (in case the bug has something to do with GTK):

ac_add_options --enable-toolkit-gtk
ac_add_options --enable-calendar
ac_add_options --enable-crypto
ac_add_options --disable-installer
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O2 -march=athlon-tbird -mcpu=athlon-tbird"
ac_add_options --enable-xft
(Reporter)

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 228646 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

7 years ago
i would say that this is NOT a duplicate of 228646.  see comment #12 of 228646, copy of which is here:

"btw before i forget: i am still seeing occasional failure of cursor keys, accompanied by failure of the cursor "blink" mechanism.  this is *different* from the above-reported bug.  this particular bug usually occurs with gmail, when the machine running firefox happens to be under particularly heavy load.  also, significant long-term usage is also required to replicate this particular bug, as well as significant memory leakage (1gb+).  but, i repeat: this is NOT the same thing as the reported bug, because only cursor keys were affected (not *all* keys)."
You need to log in before you can comment on or make changes to this bug.