Reject all cookies for a given page load

RESOLVED WONTFIX

Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED WONTFIX
15 years ago
14 years ago

People

(Reporter: James Bennett, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031030 Epiphany/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031030 Epiphany/1.0.6

Being able to reject or accept cookies on a per-domain basis is extremely
useful, but occasionally results in a situation where, during the loading of one
page, an seemingly endless series of cookie dialogs must be dealt with.  For
example, a particular page load might involve the following:

- A cookie from the domain of the page being loaded.
- A cookie from that domain's image server.
- A cookie or cookies from the site's advertising partner(s).
- A cookie from the site's hit counter.

And so on.  Dealing with each of these individually is an annoyance, and because
each cookie could come from a completely different domain, the current
cookie-rejection options are not particularly helpful.  If possible, it would be
nice to have an option like "reject all cookies while this page is loading"
which would reduce many cookie dialogs to one and alleviate the annoyance of
pages which attempt to set far too many cookies.



Reproducible: Always

Steps to Reproduce:
1. Set cookie control preferences to prompt for each cookie.
2. Visit any site which partners with MSN or has a Hitbox hit counter.
3. Be besieged by hordes of cookie dialogs at your gates.

Actual Results:  
Like Rome facing the Goths, I was shamed and defeated by a horde of barbarous
servers trying to set cookies.

Expected Results:  
Mozilla should offer an option to reject any cookie which any server tries to
set while the current page is loading.
the usefulness of this is questionable.  First, how would you know whether the
site was going to set more cookies until it prompted?  The only way you would
know is if you were returning to a page again, in which case this would only
affect you if you were not choosing to remember the decision in question.  And
for that case, its adding cruft to the dialog for the sake of someone choosing
to have the dialogs return after the first time.

I'm thinking WONTFIX for this one as well.
see reasons above, I haven't changed my mind on the rationale given
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.