Closed Bug 227068 Opened 16 years ago Closed 16 years ago

JavaScript blocks within Applet block execute when they should be ignored

Categories

(Core :: Layout, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 60724

People

(Reporter: steve53, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6a) Gecko/20031103
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6a) Gecko/20031103

As I understand the spec, content within an <Applet> block should be ignored
unless the applet can not be run.  This the behavior on IE and older versions of
Netscape.  Mozilla always executes the embedded script.

I have not yet checked if <Object> exhibits the same behavior.

For reference, the HTML is:

      <applet codebase="." code=JSAlert.class width=460 height=160
	alt="Your browser understands the &lt;APPLET&gt; tag but isn't running the
applet, for some reason."
      >
        Your browser is completely ignoring the &lt;APPLET&gt; tag!
	<script language="javascript" type="text/javascript">
	  alert('This should not display if applet runs.')
	</script>
      </applet>


Reproducible: Always

Steps to Reproduce:
1.  Open page
2.
3.

Actual Results:  
Java applet runs.  JavaScript alert pops up.

Expected Results:  
The JavaScript should not have been invoked because the Java applet started.

*** This bug has been marked as a duplicate of 60724 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.