javascript errors generated when trying to install mycroft search plugins with installer version

RESOLVED FIXED

Status

()

Firefox
General
--
major
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: duckman, Assigned: Blake Ross)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031129 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031129 Firebird/0.7+

I am unable to install new search capabilities from http://mycroft.mozdev.org .
The problem seems to be in the javascript handling as when i click on the link
to install a plugin I get the following errors in the javascript console:

Error: [Exception... "Component returned failure code: 0x80004003
(NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult: "0x80004003
(NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
file:///F:/MozillaFirebird/components/nsSidebar.js :: nsSidebar :: line 67" 
data: no]
Source File: file:///F:/MozillaFirebird/components/nsSidebar.js
Line: 67

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult:
"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
file:///F:/MozillaFirebird/components/nsSidebar.js :: nsSidebar :: line 67" 
data: no]

I believe that this is a regression of Bug 21953

Reproducible: Always

Steps to Reproduce:
1. go to http://mycroft.mozdev.org
2. i then try an install any of the search plugins by clicking on the link 
3. there is no response from the browser  and two javascript errors are thrown

Actual Results:  
plugins not installed

Comment 1

15 years ago
Works for me with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031129 Firebird/0.7+

Can anyone confirm this for Windows?
Keywords: regression
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031130 Firebird/0.7+

Please try installing into a new directory and creating a new profile, using the
MozillaFirebird.exe -p switch, and report your results here

(Reporter)

Comment 3

15 years ago
OK, i played around with new profiles, different directories and even different
install methods. I narrowed it down to a problem with the new official installer
for windows. I downloaded and unpacked the latest nightly zip and ran with a new
profile and was able to add plugins. It also worked with a new directory, new
profile and seb's unofficial installer. However, when using the official
installer with a new profile and in a new directory adding mycroft plugins failed. 

ANyone else able to confirm using the official installer?
(Reporter)

Comment 4

15 years ago
further note: 

unpacking the zip to the default directory and using the original profile also
allows installation of search plugins. Seems like a definite problem with the
installer. 

Updated

15 years ago
Summary: javascript errors generated when trying to install mycroft search plugins → javascript errors generated when trying to install mycroft search plugins with installer version

Comment 5

15 years ago
I have just confirmed this fails with the installer build from the 29th, but
works fine with the installer build from the 30th.

Can someone with enough privileges please mark this as fixed.

Comment 6

15 years ago
Fixed as per user comment #5. Thanks to all of you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.