Composer adds spurious newlines to HTML source

RESOLVED DUPLICATE of bug 176866

Status

RESOLVED DUPLICATE of bug 176866
15 years ago
14 years ago

People

(Reporter: bhalco, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Composer, when set to "Retain original source formatting", inserts spurious
newlines in the HTML source.

Reproducible: Always

Steps to Reproduce:
1. Open a Composer window.  View HTML Source. It looks like:
---
<html><head><meta http-equiv="content-type" content="text/html;
charset=ISO-8859-1"><title></title></head><body><br>
</body></html>
---
2.  Insert a space between<TITLE> and </TITLE>.  Switch to Normal view, then
back to HTML Source.  The source now looke like
---
<html><head>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
<title> </title>
</head><body><br>

<br>
</body></html>
---
3. Now add a second space between <TITLE> and </TITLE>, switch to Normal view
and back to HTML Source view.  The source now looks like
---
<html><head>

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
<title> </title>

</head><body><br>


<br>

</body></html>
---

Actual Results:  
See above

Expected Results:  
Composer should not have performed *any* reformatting at all.  Should have only
added the two spaces.

This is a simple contrived example.  Normal editing will result in repeated
added newlines.  The newlines tend to be grouped together, and sometimes include
a pair of space characters (0x20).  I am currently using Mozilla 1.5, but have
seen this behavior for a long time (years).  The problem can also be seen with
Mozilla 1.5 on Windows.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 176866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Sorry, I accidentally made this a duplicate of the wrong bug: bug 176866 is
itself a duplicate of bug 97278, which seems to be the root bug, and is still open.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.