jsobject should be defined as jlong.

VERIFIED DUPLICATE of bug 227170

Status

Core Graveyard
Java: Live Connect
--
major
VERIFIED DUPLICATE of bug 227170
15 years ago
8 years ago

People

(Reporter: Shanmu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.5) Gecko/20031112
Build Identifier: Mozilla/5.0 (X11; U; OSF1 alpha; en-US; rv:1.5) Gecko/20031112

In the mozilla header files jsobject is 
defined to be an int, and all the interfaces into mozilla that pass
jsobject (Java Script objects) are also int.  Unfortunately, a
java script object is not an int, but a pointer. So I can write an
applet that will cause the mozilla crash on a 64-bit OS, because
pointers are 64 bits. 
The definition of jsobject should be changed "to jlong" 
at the following places.

./js/src/liveconnect/nsILiveconnect.h:typedef jint jsobject;
./js/src/liveconnect/nsISecureLiveconnect.h:typedef jint jsobject;


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 227170 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.