Table colums appear in wrong order (reversed)

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Guy Geens, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

The html page in attachment contains a small table with numbers. (It was
extracted from a larger page that contains more tables like this.)

Mozilla 1.5 and 1.6a display the numbers in the reverse order. Mozilla 1.4
displays the correct ordering.

If you remove the style for .right, the table is displayed correctly.

Reproducible: Always

Steps to Reproduce:
1. Open example page attached to this bug.
2. Compare order of numbers displayed by Mozilla to the correct sequence.

Actual Results:  
Table contains:
Main 202 174 18 10

Expected Results:  
Table contains:
Main 10 18 174 202
(Reporter)

Comment 1

14 years ago
Created attachment 136584 [details]
Test case

Comment 2

14 years ago
Confirming (current Linux CVS trunk build)

OS->All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Updated

14 years ago
Summary: Table colums appear in wrong order → Table colums appear in wrong order (reversed)

Comment 3

14 years ago
The current rendering is correct.

The table-cells becomes ordinary blocks since there they are 'float:right'.
See http://www.w3.org/TR/CSS21/visuren.html#dis-pos-flo

Right-floating blocks stack from right to left in document order.

-> INVALID
Keywords: testcase

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.