Java handler can't cope with any delay in load-time

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Gábor Katona, Assigned: Kyle Yuan)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; hu-HU; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; hu-HU; rv:1.5) Gecko/20031007

Using Mozilla 1.5 with Adblock 0.5 d2 nightly 23 (http://adblock.mozdev.org/) to
block flash and other contents. 
On any page with Java, Mozilla with Adblock hangs, and usually the only solution
is to kill it. Disabling Adblock doesn't help, only uninstall solves the problem.
According to the discussion in Adblock's forum
(http://aasted.org/adblock/viewtopic.php?p=731), the problem is related to the
JAVA handler. This is a quote from the developer in this forum:

"Alright- as far as Adblock goes, this issue cannot be resolved.

There's a major bug in the java handler where Content Policy is concerned.
Basically, for live io-connections, the handler can't cope with any delay in
load-time... and the policy-system is nothing but one big delay.

The latest nightly is set to do absolutely nothing if an applet is encountered.
This still results in java-console errors for me, and even an occassional
hard-crash. The problem is outside Adblock's scope.

There's no way to keep the policy-system from handling applets. When it
encounters them, the load is delayed and Adblock is consulted. If the
java-handler accounted for this, there wouldn't be an issue. Additionally, the
java-handlers for major platforms differ, so the conflict wont present
consistently."

Reproducible: Always

Steps to Reproduce:
1. install Adblock
2. go to a web page with java (eg. http://livecharts.com)
Actual Results:  
Mozilla stops responding

Expected Results:  
run the Java aplet based on Adblock's response to shouldload

Comment 1

15 years ago
*** Bug 227855 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

15 years ago
-> me
Assignee: joshua.xia → kyle.yuan
(Reporter)

Comment 3

14 years ago
After installing Sun Java VM 1.5 beta with Moz 1.6 the problem disappeared.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
Nothing in Mozilla was broken or fixed.

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
(Or a bug/patch was not identified.)

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.