folder menus don't show icons

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Malte Rücker (mbr), Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

15 years ago
(folder menu = dropdown containing available accounts/folders)

All folder menus are missing the corresponding folder/account icons in front of
the names. I'm not sure if they had been removed on purpose from Thunderbird but
they are contained in MailNews.
Example folder menus in: Message Filters dialog, Subscribe dialog, Search
Messages dialog and more...

Just for clarification: icons do work in Move/Copy message menus like "Message /
Move".
(Reporter)

Comment 1

15 years ago
Created attachment 136608 [details]
example folder menu

a picture says more than...
It's one example of a folder menu in Tbird. The same one in MailNews has folder
icons.

Comment 2

15 years ago
The SeaMonkey build I downloaded tonight did not have the folder icons in the
search messages dialog.
(Reporter)

Comment 3

15 years ago
I used the Modern theme for Seamonkey which shows icons in the dropdown. Then I
switched to Classic and the icons were gone, just like in Thunderbird.
Would this be a valid bug for Seamonkey? All necessary css etc. seems to be
there but there are no icons shown.

Comment 4

15 years ago
Classic menulists have been iconless for nigh on two years, surely someone would
have complained before?

Anyone filing a patch should check the HTML compose Insert Image dialog to
ensure that the Align dropdown displays correctly.
(Reporter)

Comment 5

15 years ago
So it's a valid bug and not something that has been taken out on purpose? I did
not find any similar bug reports but you're right - it's unlikely that there
isn't one.
First I thought this is something that broke during the conversion to the new
toolkit (and I compared with the modern theme of mozilla only where this works,
as commented earlier) this is why I reported under Thunderbird.

Can you give a rough overview of what needs to be done? Is this theme-related
only? Thanks!

Comment 6

15 years ago
Well, speaking as a Seamonkey XP Apps peer, I have no objections to a patch that
would restore the icons to the menulists in the classic theme, assuming it
worked in all cases. But presumably someone deliberately disabled them, I have
not been able to determine why.

Comment 7

15 years ago
http://lxr.mozilla.org/mozilla/source/themes/classic/global/win/menu.css#159
http://lxr.mozilla.org/mozilla/source/toolkit/skin/win/menu.css#155

Hewitt's mass theme simplification landing is to blame although I don't see a
reason stating why the icons were killed.

Comment 8

15 years ago
Created attachment 137914 [details] [diff] [review]
Revive classic folder icons

Updated

15 years ago
Attachment #137914 - Flags: superreview?(mscott)
Attachment #137914 - Flags: review?(neil.parkwaycc.co.uk)

Comment 9

15 years ago
Comment on attachment 137914 [details] [diff] [review]
Revive classic folder icons

Did you read comment 4? I think not...
Attachment #137914 - Flags: review?(neil.parkwaycc.co.uk) → review-

Comment 10

15 years ago
Created attachment 137973 [details]
Insert Image Before/After

Post-patch actually uses the icons in the <menupopup/>.

Updated

15 years ago
Attachment #137914 - Flags: review- → review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #137914 - Attachment is obsolete: true
Attachment #137914 - Flags: superreview?(mscott)
Attachment #137914 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #137973 - Attachment is obsolete: true

Comment 11

15 years ago
Comment on attachment 137973 [details]
Insert Image Before/After

That's either a Thunderbird or a Composer++ screenshot; try it in Mozilla and
see that it doesn't work.

Comment 12

15 years ago
Created attachment 139747 [details] [diff] [review]
Port the toolkit way to seamonkey

Instead of restricting the width and height of the menuitem icons, just place a
16px width to the left of the menuitem text and allow the icons to be the width
and height of their image.

Updated

15 years ago
Attachment #139747 - Flags: superreview?(mscott)
Attachment #139747 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

15 years ago
Attachment #139747 - Flags: superreview?(mscott) → superreview+

Comment 13

15 years ago
Comment on attachment 139747 [details] [diff] [review]
Port the toolkit way to seamonkey

3 in 1: neat. r=me on Seamonkey.
Attachment #139747 - Flags: review?(neil.parkwaycc.co.uk) → review+

Comment 14

15 years ago
a-
Basically, it will add a 16px left space for all our menulist menuitems.
I think that the default should still be no icon for menulists, but that the
class "menuitem-iconic" should give the possibility to add one.
I encountered this bug for the add bookmark dialog. I added a workaround to
display the icon, and planned to revisit our menu anonymous contents for 0.9.
I am not likely to do it before two weeks, so Stephen if you can come up with a
fix earlier, just go.
*** Bug 230007 has been marked as a duplicate of this bug. ***
PLEASE REFRAIN from checking in that fix!!! It's going to add a left padding to
all menuitems and that's bad. It's possible to rewrite the rule that assigns
a "display: none" to icons that way :

.menulist-menupopup > menuitem:not([type="checkbox"]):not([type="radio"]) >
.menu-iconic-left,
menulist > menupopup > menuitem:not([type="checkbox"]):not([type="radio"]) >
.menu-iconic-left,
.menulist-menupopup > menu > .menu-iconic-left,
menulist > menupopup > menu > .menu-iconic-left {
  display: none;
}

and that would allow <menuitems type="checkbox"...> to show up *and* normal
menulists to preserve their current behavior...

Updated

14 years ago
Attachment #139747 - Attachment is obsolete: true

Comment 17

13 years ago
Are there still folder menus without icons ?

The folder menus in search messages and message filter dialog have changed and
now show icons.

So this bug can be closed ?!

Comment 18

13 years ago
That's because they're not true menus any more ;-)
QA Contact: front-end

Comment 19

10 years ago
WFM version 3.0a2pre (2008061103)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.