If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clean up in Download Manager is slow for many records

VERIFIED DUPLICATE of bug 211632

Status

()

Toolkit
Downloads API
P2
normal
VERIFIED DUPLICATE of bug 211632
14 years ago
9 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({perf})

unspecified
mozilla1.7.5
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031201 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031201 Firebird/0.7+

With download history over 100 records, pushing "Clean up" button in Download
Manager almost freezes on a PC with 2Ghz CPU.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

14 years ago
Keywords: perf

Comment 1

14 years ago
It's much faster in 12/01 than in 11/30.  But since you filed this against the 
12/01 build, I guess you think it's still too slow.
I agree, it can still be slow. After 1.0 we'll consider moving the downloads
datasource over to use mork instead of RDF/XML, and this should provide further
speed improvements. 
Severity: minor → normal
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Firebird1.0
Assignee: blake → bugs
Status: ASSIGNED → NEW

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 211632 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.