If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

url drop down history lost after windows crashes

RESOLVED DUPLICATE of bug 102519

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 102519
14 years ago
13 years ago

People

(Reporter: Kaki, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

after windows crashes, typing anything in the address bar will not trigger the
drop down list anymore

Reproducible: Always

Steps to Reproduce:
1.windows crashes
Actual Results:  
drop down history lost

Expected Results:  
keep the drop down list

reproducible the last 2 times windows crashed. don't even want to try again!
seems like an obvious bug but bug search returns nothing similar.

Comment 1

14 years ago
Happened to me also.
Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.6b) Gecko/20031203 Firebird/0.7+

I would expect the url history for the session Windows crashed in to be lost,
but not ALL the history.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 221797 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
This is IMO not a dupe of bug 221797.

The attachment 136736 [details] [diff] [review] (bug 221797, comment 21) fixes a Win9x/ME only issue in
the mork module. The patch has no effect on WinNT/2K/XP.

The global history (history.dat) uses mork. The drop down history
(localstore.rdf) uses RDF which is not affected by the patch.

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 63292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

14 years ago
not only session addition, but all the drop down urls are also lost.

Comment 6

13 years ago
Reporter, can you reproduce this on a newer build of Mozilla Firefox?  I'm
moving this to Location Bar/Autocomplete.
Component: General → Location Bar and Autocomplete

Comment 7

13 years ago
Happens to me, even when Windows does not crash. History gone, all the drop down
urls also gone.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Is this clearing all the history, or is it only clearing the URL drop down bar?
If this clears all the history, it should be duped to bug 102519.

Comment 9

13 years ago
re comment 3 "The drop down history (localstore.rdf) uses RDF which is not
affected by the patch."
Are you sure? I think it is stored in history.dat too.

If anybody experienced autocomplete urls loss *without* history loss, reopen.

*** This bug has been marked as a duplicate of 102519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 10

13 years ago
> Are you sure? I think it is stored in history.dat too.
Yes, correct. Mozilla stores drop down history in localstore.rdf but Firefox
uses history.dat for global and drop down history.
You need to log in before you can comment on or make changes to this bug.