Autocomplete fails if "quotes" surround Display Name in Address Book

RESOLVED DUPLICATE of bug 168204

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 168204
14 years ago
9 years ago

People

(Reporter: guanxi, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

When typing recipient names in the To/CC/BCC/etc field, Autocomplete fails find
the address if the Display Name in the Address Book is surrounded by quotes.



TO DUPLICATE

1.   Open the Address book, click New Card
2.   In the Display field, type:  "Jane User"  [INCLUDE THE QUOTES!]
3.   In Email field, type:        juser@example.com
4.   Click OK to save, and then close the address book

5.   In MainNews, click Compose
6.   In the To: field, start typing:  Jane
     Note: Autocomplete does not list "Jane User"
7.   In the To: field, start typing:   "Jane User"  [INCLUDE THE QUOTES!]
     Note: Autocomplete lists "Jane User"


EXPECTED RESULTS:
  Autocomplete lists "Jane User" as an option, whether or not you type the quotes.


ACTUAL RESULTS:
  Autocomplete does not list "Jane User" as an option, unless you type the quotes.



CAUSE:

Many e-mail addresses come in this format (including the quotes):
   "User Name" <account@domain.com>

They are automatically added to the Address Book, depending on your settings,
but are then useless for Autocomplete.  Furthermore, I think it will confuse and
frustrate many users, who will look at their address book and say: 'He's in
there, why doesn't Autocomplete work?'.


Note: To prevent confusion:  If the e-mail address and Display Name begin with
the same letters (e.g. "Jane User" and janeuser@example.com) then the procedure
above won't duplicate the error, because Autocomplete will find the e-mail address.

Comment 1

14 years ago
Dupe of bug 168204?
(Reporter)

Comment 2

14 years ago
Yup, dupe ... autocomplete belongs in the Composition component, which is why I
didn't find it, but I'll take that up over there.

*** This bug has been marked as a duplicate of 168204 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.