Find Again fails if "Find in this Page" window open

RESOLVED FIXED

Status

SeaMonkey
UI Design
--
minor
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Daniel B., Assigned: Manish Jethani)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

The Find Again command fails if the "Find in this Page" window is open.
Instead of searching for matching text, the command just gives focus to the 
"Find text" text box in the "Find in this Page" window.

This applies whether the Find Again command is executed via Control-G, F3, 
or the Find Again menu item on the Edit menu.

Note the poor usability of the current behavior:  To do something as simple
as Find Again using the keyboard, the user has to first close the "Find"
window (and if the Find window doesn't have focus, there's apparently no
simple non-mouse way close it).


Reproducible: Always

Steps to Reproduce:
1.  View some web page containing text.
2.  Search for some text (using the Find in This Page command (via the menu 
    item or Control-F)).
3.  With the "Find in this Page" window still open, press Control-G or F3 or 
    invoke the Edit menu's Find Again menu item.
4.  Note that no further searching occurs, and focus is given to the "Find text"
    text box in the "Find in this Page" window.
5.  Close the "Find in this Page" window.
6.  Invoke the Find Again command again.
7.  Note that it searches for the text.

Actual Results:  
See steps 4 and 7.

Expected Results:  
In step 4, Mozilla should have done a search as it does in step 7.

Comment 1

15 years ago
confirming and moving to XP Apps: GUI Features.
Lowering severity to Minor as an easy workaround is present: close the "find in
this page" dialog.
Assignee: general → guifeatures
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
Created attachment 146420 [details] [diff] [review]
Ignore find dialog even if it's open

I agree that the focus shouldn't be set back the find dialog. Either we close
the find dialog and continue the search, or we ignore it and continue the
search. I think ignoring it is a better option, since the user may want to keep
it open on the side to modify the query. In any case, the user should *not*
have to manually close the find dialog in order to continue the search further.
That's very annoying.

Updated

14 years ago
Attachment #146420 - Flags: superreview?(rbs)
Attachment #146420 - Flags: review?(akkzilla)

Comment 3

14 years ago
Comment on attachment 146420 [details] [diff] [review]
Ignore find dialog even if it's open

Sorry, didn't see this request when it happened.  But it looks good.  r=akkana.
Attachment #146420 - Flags: review?(akkzilla) → review+

Comment 4

14 years ago
Comment on attachment 146420 [details] [diff] [review]
Ignore find dialog even if it's open

sr=rbs
Attachment #146420 - Flags: superreview?(rbs) → superreview+

Comment 5

14 years ago
mozilla/xpfe/communicator/resources/content/findUtils.js 	1.13
Assignee: guifeatures → manish.jethani
Product: Core → Mozilla Application Suite
Any reason this wasn't resolved 2 years ago?  It seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.