New Hotmail code removes the ability to open new tabs easily from within Hotmail

RESOLVED DUPLICATE of bug 138198

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 138198
14 years ago
13 years ago

People

(Reporter: Paul Shuttle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031027 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031027 Firebird/0.7+

In the previous version of Hotmail (i.e. before a few days ago), links in
e-mails opened up in a new tab as normal, via the mouse wheel button. In the new
revision (i.e. NOW), this is no longer possible, and clicking the middle mouse
button on any e-mail link does nothing. Links can still be opened by right
clicking -> Open Link in New Tab, but this is obviously an inconvenience.

There's a thread about this issue over at the MozillaZine forums here:
http://forums.mozillazine.org/viewtopic.php?p=283694

I'm not sure if there's anything that can be done to fix this, but here's
hoping. Going by that thread, it appears to happen in all Firebird releases, and
I don't see anything which mentions this is a Windows only problem.
Unfortunately I don't have Linux installed to check.

Reproducible: Always

Steps to Reproduce:
1. Log in to an e-mail account on www.hotmail.com
2. Open an e-mail with a link
3. Try and open the link into a new tab using the middle mouse button

Actual Results:  
Nothing happens.

Expected Results:  
Opened the link into a new tab.
(Reporter)

Comment 1

14 years ago
Additional: This also appears to be the case for any links from within the
Hotmail system - So even opening e-mails themselves in tabs is made impossible,
unless you use the aforementioned workaround.

Comment 2

14 years ago
This isn't really a bug, more of an enhancement request. It's a Javascript
issue. Rather than providing a proper web address on an href, Hotmail now uses
onclick events to call a JS function.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 138198 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.