Want available filters on "Sender" to be avail for "To, CC, To or CC"

RESOLVED DUPLICATE of bug 187768

Status

--
enhancement
RESOLVED DUPLICATE of bug 187768
15 years ago
10 years ago

People

(Reporter: scunliffe, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I find that I am now on a few "spam lists", that I will be stuck with till ???
That said, a quick peek at these messages, shows that although the content
varies, the many of the "people" on the To/CC list, tend to be cropping up
repeatedly.
Since I never expect to receive email from "jblthk4589@somemail.com" (and
similar), I added a few (10) of these repeated "contacts" to a new address book
"Spammed like me".  I was disapointed though, when I went to my message filters,
hoping to find the option to...
If ["To or cc"] | ["Is in my address book"] | ["Spammed like me"]

I can't use the "sender" option, as it is randomly generated, but I can almost
guarentee that my spammer, isn't going to place me on a fresh random list every
time, and thus the To/cc option would be great.

Reproducible: Always

Steps to Reproduce:
1. Create a message Filter
2. Select [To:] or [CC:] or [To or cc] as the "item" being checked
3. Note that the options available for [Sender] are NOT available for To/CC

Actual Results:  
I could not create the desired message filter, or similar.

Expected Results:  
Pressuming that the "is in my address book/is not in my address book" filters,
compare the "from" email address, against the selected address book, then I
think the ability to do so, on the To:/Cc: fields would also be helpful.

I'm still on Mozilla 1.4.  If this issue has been resolved with 1.5, please
ignore this feature request.

Comment 1

15 years ago
Confirming.  "Is in my Address Book" and "Isn't in my Address Book" should be
added to "To or CC:", "To:" and "CC:".  "begins with" and "ends with" should be
added to the "To or CC:" field as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 187768 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.