Junk Mail controlls ignore "additional eMail Adress" when deciding Junk status

VERIFIED DUPLICATE of bug 210893

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED DUPLICATE of bug 210893
14 years ago
13 years ago

People

(Reporter: dominik, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

In Mozilla Junk Mail controlls, it is possible to choose:
[X] Do not mark messages as junk mail if the sender is in my address book.
This works fine, except the fact, that only the primary email adress in the
adress book is considered, but not the additional email adress. 

(this bug belongs more to junk mail controlls than to Adress Book, but i didn't
find the right component)

Reproducible: Always

Steps to Reproduce:
1. Configure your junk mail controlls with:
[X] Do not mark messages as junk mail if the sender is in my address book.

2. recieve a junk email from anyone's primary address
--> the mail will NOT be marked as junk.

3. recieve a junk email form anyone's additional email address
--> the mail will be marked as junk


Expected Results:  
If junk mail controlls are configured as:
[X] Do not mark messages as junk mail if the sender is in my address book

emails should not be marked as junk, if the email adress is either a primary or
an additional email of the adress book.

Comment 1

14 years ago
Dupe of Bug 210893? I don't know if this is still a problem.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 210893 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.