JS Console does not show how contents are filtered

RESOLVED DUPLICATE of bug 176177

Status

()

Core
XUL
--
enhancement
RESOLVED DUPLICATE of bug 176177
14 years ago
13 years ago

People

(Reporter: Devon Miller, Assigned: jag (Peter Annema))

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

The JS Console has options to display 'All", 'Errors', 'Warnings', or 'Messages'.

It does not have an indication of which of these is in effect.

There needs to be some indication when you're not being shown all of the
messages. I spent the last 30 minutes tweaking a page without realizing I was
throwing an exception. The JavaScript Console was in 'warnings' mode and I
didn't know it.

Reproducible: Always

Steps to Reproduce:
1. Load a page the generates both errors and warnings
2. Open the JavaScript Console
3. Select Warnings

Actual Results:  
You will see only the warnings, no errors, but no indication that information is
being suppressed.

Expected Results:  
When something other than 'All' is selected, there should be some indication
that you are not seeing everything.

Comment 1

14 years ago
Works fine for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031202.

Could you please try a current build?

Comment 2

14 years ago
WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b)
Gecko/20031203. The background/area around the option turns white.
Reporter, what theme are you using?

Comment 4

14 years ago
maybe he meant firebird?
No, he's just using the Classic theme, which needs some fixin'.  Modern shows a
very different color there.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 6

14 years ago
I don't know why the styles aren't applying, DOM inspector shows them and the
correct computed style. BTW this works for me in a Dec 1 MingW build, the
background of the selected option should be white (3d highlight), but it doesn't
work in my 1.6b Linux nightly in the JS console or HTML Composer.

Comment 7

14 years ago
I updated my MingW build and it still works... perhaps my other build broke.
Odd.  All of my builds (nightly, vanilla debug, patched opt, etc) show the
problem in the classic theme.  I've not done any debugging on it, and I won't be
able to until weeks from now.
Mail from glazou re: similar problem in composer:

  Find toolbarbutton.css and take a look at the first
  rule at the top, the global rule for toolbarbutton.
  The only significant difference between classic and modern here is

     -moz-appearance: toolbarbutton

  The bug is in the appearance. I forces the background of the toolbarbutton
  and does not allow any other value, even tagged !important.
This also affects toolbarbuttons in Standalone Composer/Nvu
Over to widgets.

The mac version of this CSS file does NOT set moz-appearance unconditionally --
only in some states.  I think the Windows and Unix versions should follow suit.
Assignee: js-console → jag
Component: JavaScript Console → XP Toolkit/Widgets
Keywords: helpwanted

Comment 12

14 years ago
Perhaps the -moz-appearance code could be made to respect the checked state.
Perhaps, yes.

Comment 14

14 years ago
It looks as if the code for classic -moz-appearance toolbarbuttons doesn't
override the background colour, although I don't know what Windows XP theme
support would do as the code doesn't seem to draw XP toolbarbuttons...

Comment 15

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040313
default (classic) theme.

tested JS Console with a warnings only, filter was working, and filter setting
displayed as a white background. 

Comment 16

13 years ago

*** This bug has been marked as a duplicate of 176177 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.