m12 build no longer works as browser plugin for Allaire Homesite

RESOLVED WONTFIX

Status

defect
P3
major
RESOLVED WONTFIX
20 years ago
8 years ago

People

(Reporter: nicholls, Assigned: locka)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

()

The m12 release does not allow one to browse with Mozilla as the selected
internal browser engine in Allaire Homesite (4.5 and 4.0.1): it just shows a
blank window.  Earlier milestone releases do apparently work.

The problem appears to be nkres.dll, which appeared for the first time (AFAIK)
in m12.

I have logged the file open/close activity when Mozilla/npmozctl.dll is called
by Homesite to act as internal browser.  Everything goes well until nkres.dll is
opened, then it just stops, no further action occurs and Homesite can crash.

Checklist:

npmozctl.dll registered with regsvr32,
additional Win98 registry entries added as per Adam Lock's page,
PATH set correctly

I can send the log file that shows what happens when npmozctl is called by
Homesite (2k zipped text file) if that would help. (I have sent to Adam Lock via
email).

David Nicholls
I decided to uninstall m12 and install m11.  The m11 ActiveX plugin *works fine*
with Homesite 4.5 (though it's a bit flakey and I can trigger crashes, it does
function as a layout engine for Homesite).

I did a file open/close log for the m11 plugin and traced it through to where
m12 stalled: in the m11 version of npmozctl, the dll called is nkresrc.dll,
which opens and proceeds as expected.  In m12, the dll is nkres.dll, which
causes the stall.

DN
Try with the latest version of the control
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
Still not working in HomeSite 4.5.2 and Moz 2001072622.

Mr. Lock, any reason for WONTFIX?  Is this a HomeSite problem or a Mozilla one?
Nevermind.

Got it to work!  (Partly using these instructions:)
http://www.bradsoft.com/topstyle/support/gecko.asp

How to preview your code using Gecko (inside HomeSite/TopStyle):

1. Run regedit; navigate to HKEY_LOCAL_MACHINE\Software\Mozilla. 
Create a string value BinDirectoryPath under this key with the value being the 
path to the Mozilla bin directory, such as, c:\mozilla\bin.

2. Run regsvr32 "C:\Program Files\Mozilla\mozctl.dll"
3. Run regsvr32 "C:\Program Files\Mozilla\mozctlx.dll"

If you don't follow the above steps, HomeSite throws a "catastrophic error".

If you follow the above steps, but load HomeSite's HTML help inside the Gecko 
control, HomeSite immediately crashes.

Performance: Takes ~5 seconds to load, unlike IE's control, which takes half a 
second on this P2.  Still rocks.

Now, if I could get side-by-side Gecko+IE previews in Textpad ...
One more thing:

The embedded control doesn't work when using a DOCTYPE:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Take out the DOCTYPE and it works fine.
Is this intended behavior?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.