Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Yann Trocheris, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

unable to connect to an Apache Tomcat/4.1.18 application :
I get this message : 
org.apache.jasper.JasperException: Missing message for key
common.AppMessageBienvenue

I cannot give you access to this app as it is a corporate one

Root cause :
javax.servlet.ServletException: Missing message for key common.AppMessageBienvenue
	at
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:530)
	at org.apache.jsp.logon_jsp._jspService(logon_jsp.java(Compiled Code))
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java(Compiled Code))
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java(Compiled
Code))
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java(Compiled
Code))
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java(Compiled Code))
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java(Compiled Code))
	at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java(Compiled Code))
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java(Compiled
Code))
	at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java(Compiled
Code))
	at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java(Compiled
Code))
	at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java(Compiled
Code))
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:530)
	at java.lang.Thread.run(Thread.java:512)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
load the logon page

No link with the Theme : it happens with the default Mozilla Theme

Comment 1

15 years ago
--> Browser
Assignee: blake → general
Component: General → Browser-General
Product: Firebird → Browser
QA Contact: general
Version: unspecified → Trunk

Comment 2

15 years ago
it's a server-side error, not a client-side error.
What happens with other browsers ? Perhaps Mozilla is triggering an issue that
doesn't show up with IE but it's probably up to the server to fix the root issue.
Please, try to create minimized testcase of Your problem (something with
login/logout part?)
I'm almost sure it's not Mozilla's problem since You can meet with similar one
on google and it's related to bad instalation of included jars.

Comment 4

15 years ago
This is clearly a server-side exception. One of the classes in the stack (I'd 
guess org.apache.jsp.logon_jsp._jspService) can't find the 
key 'common.AppMessageBienvenue' in the applications .properties file.

INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
can't tell if it is the server-side problem, just can tell that IE works great
with this App
(Reporter)

Comment 6

15 years ago
Created attachment 136789 [details]
the login Page in IE
(Reporter)

Comment 7

15 years ago
Created attachment 136790 [details]
The login page in Mozilla
Malcolm: Are you sure that this key should be in .properites file? Meaby it
should be downloaded from GET/POST values?

Second guess is that IE loads page from cache... Yann: is this first page in
application, or a result of sending any data?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 9

15 years ago
It is the first Page of the app.
nothing has been done before
Then it cannot be Mozilla's bug due to HTTP protocol nature.
Browser asks for content and Application Server gives it back - mozilla cannot
influence it's work.
Without testcase we're not able to help You - I can only agree with Comment 4.

Marking as Invalid. Please, give us a minimized tescase which reproduce this bug
- then we can work on it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.