If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hang trying to display empty select list with css-style in table

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: Hejko Schaefer, Unassigned)

Tracking

({hang, qawanted, testcase})

Trunk
x86
Windows XP
hang, qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Mozilla (1.4 und 1.5 tested) hangs (high CPU-usage) while trying to display this
page:

<html>
<head>
<style type="text/css">
<!--
select {
  font-size: 10px;
  width: 100%; height:100px;
}
-->
</style>
</head>
<body>
<table >
<tr>
 <td>
<form>
  <select name="SelectFiles" size="10" multiple>
</select>
</form>
 </td>
</tr>
</table>
</body>
</html>



Reproducible: Always

Steps to Reproduce:
open the example
Actual Results:  
page loaded but is not displayed, very high CPU-usage

Expected Results:  
like the following example, only empty:

<html>
<head>
<style type="text/css">
<!--
select {
  font-size: 10px;
  width: 100%; height:100px;
}
-->
</style>
</head>
<body>
<table >
<tr>
 <td>
<form>
  <select name="SelectFiles" size="10" multiple>
<option value="nothing">nothing here...</option>
</select>
</form>
 </td>
</tr>
</table>
</body>
</html>

Updated

14 years ago
Keywords: hang
Summary: hanging trying to display empty select list with css-style in table → Hang trying to display empty select list with css-style in table

Comment 1

14 years ago
Created attachment 136792 [details]
Reporters testcase

Updated

14 years ago
Keywords: testcase

Comment 2

14 years ago
WFM, Windows XP Gecko/20031203

Comment 3

14 years ago
My computer hangs with Windows XP Gecko/20031203, Firebird

Comment 4

14 years ago
Ignore my early comment. I can reproduce it with the clean profile.

I had the 'minimum font size' set to 14 (font.minimum-size.x-western) and
mozilla worked fine. When I reset the setting to the default, mozilla hanged
viewing the testcase.
(Reporter)

Comment 5

14 years ago
I tried to strip the example of anything that is not needed to reproduce the
bug. I could only reproduce it with the width measured in % and height and
font-size given. I have tried it with "height: 100%" instead of "height: 100px"
and mozilla hangs again. HTH. "select" does not need to be "multiple" though to
reproduce the bug. If I use percent with font-size then everything is okay. If I
do not use percent with width then everything is okay. Height in percent and
width in pixels does not hang either. Again: HTH
(Reporter)

Comment 6

14 years ago
Reproduceable up to font-size: 13px, with 14px it's okay. Same with 9pt/10pt
(96dpi). It seems as if this has nothing to do with the given height of the
select-listbox though.
Confirming - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031202 Firebird/0.7+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 136850 [details]
reduced testcase

I removed unnecessary attributes and tags
(Reporter)

Comment 9

14 years ago
Created attachment 136852 [details]
corrected reduced testcase

The reduced testcase by Zbigniew Braniecki doesn't hang! It works fine on
Mozilla 1.4 [ Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 ]
The font-size has to be in the style.
Hmm... My FB (new profile) freezed on my testcase.
This is _so_ unlikely to be parser.  I'm also pretty sure this is a dup. 
Someone needs to get a stack from the hang....
Assignee: parser → nobody
Component: HTML: Parser → Layout
Keywords: qawanted
QA Contact: core.layout
Whiteboard: DUPEME

Comment 12

14 years ago
Created attachment 138366 [details]
stacktraces

loading the testcase, I get:
###!!! ASSERTION: nsFrameManager::GenerateStateKey didn't find content by type!
See bug 139568: 'index > -1', file nsContentUtils.cpp, line 1496

it seems to be doing reflow indefinitely (telling gdb to "finish" makes it all
the way down out of reflow).  I've attached 3 stacks.
WFM, 2004-08-07-06 trunk Linux
(Reporter)

Comment 14

13 years ago
Seems to be fixed in 1.7.2 ???
WFM, 2004-08-06-07 trunk Linux

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Sorry, the last comment should have been:

WFM, 2004-08-06-07 trunk Windows XP
                         ^^^^^^^^^^
-> WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.