browser always crashes on printing following page

RESOLVED DUPLICATE of bug 229184

Status

()

Core
Printing: Output
--
critical
RESOLVED DUPLICATE of bug 229184
14 years ago
14 years ago

People

(Reporter: Vytautas, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
All
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

browser always crashes on printing
http://www.1stsingaporewebhosting.com/webdesign/googleoptimization.shtml


Reproducible: Always

Steps to Reproduce:
1.open with firebird 
http://www.1stsingaporewebhosting.com/webdesign/googleoptimization.shtml
2.press print  

Actual Results:  
browser crashes

Expected Results:  
printed document

Comment 1

14 years ago
wfm 20031202 Win2k
Severity: normal → critical
Keywords: crash, stackwanted

Comment 2

14 years ago
I see this on Moz LInux 2003121508 -  Note I used print to file.

Comment 3

14 years ago
Print-to-file in Landscape mode crashes 2003-12-20-07 trunk Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 4

14 years ago
Reproduced on linux using seamonkey CVS build 20031230. Here's a partial stack
trace:

Program received signal SIGSEGV, Segmentation fault.
0x40ee4434 in nsIFrame::GetNextSibling() const (this=0x0)
    at ../../../../dist/include/layout/nsIFrame.h:693
693     ../../../../dist/include/layout/nsIFrame.h: No such file or directory.
        in ../../../../dist/include/layout/nsIFrame.h
(gdb) bt 20
#0  0x40ee4434 in nsIFrame::GetNextSibling() const (this=0x0)
    at ../../../../dist/include/layout/nsIFrame.h:693
#1  0x40f2a37d in nsLineBox::LastChild() const (this=0x0)
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsLineBox.cpp:249
#2  0x40eedc9a in nsBlockFrame::PushLines(nsBlockReflowState&,
nsLineList_iterator) (this=0x890f258, aState=@0xbfff7100, aLineBefore=
      {mCurrent = 0x890f294, mListLink = 0x890f294})
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsBlockFrame.cpp:4265
#3  0x40eec4a4 in
nsBlockFrame::PushTruncatedPlaceholderLine(nsBlockReflowState&,
nsLineList_iterator, nsIFrame*, int&) (this=0x890f258, aState=@0xbfff7100,
    aLastPlaceholder=0x0, aKeepReflowGoing=@0x0)
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsBlockFrame.cpp:3391
#4  0x40eec8d9 in nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&,
nsLineLayout&, nsLineList_iterator, int*, unsigned char*, int, int) (this=0x890f258,
    aState=@0xbfff7100, aLineLayout=@0xbfff684c, aLine=
      {mCurrent = 0x8958914, mListLink = 0x890f294},
    aKeepReflowGoing=0xbfff6e10, aLineReflowStatus=0x0, aUpdateMaximumWidth=0,
    aDamageDirtyArea=1)
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsBlockFrame.cpp:3492
#5  0x40eec43c in nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState&,
nsLineList_iterator, int*, unsigned char*, int, int) (this=0x890f258,
    aState=@0xbfff7100, aKeepReflowGoing=0xbfff6e10,
    aLineReflowStatus=0xbfff6cdb "\002(w7A(qÿ¿\001", aUpdateMaximumWidth=0,
    aDamageDirtyArea=1)
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsBlockFrame.cpp:3370
#6  0x40eec2fd in nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&,
nsLineList_iterator, int*, int, int) (this=0x890f258, aState=@0xbfff7100,
    aKeepReflowGoing=0xbfff6e10, aDamageDirtyArea=1, aUpdateMaximumWidth=0)
    at /home/kherron/cvs/mozilla/layout/html/base/src/nsBlockFrame.cpp:3314
#7  0x40eeaa8a in nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineList_iterator, int*, int) (this=0x890f258, aState=@0xbfff7100, aLine=
      {mCurrent = 0x8958914, mListLink = 0x890f294},
    aKeepReflowGoing=0xbfff6e10, aDamageDirtyArea=1)

This is the same stack trace that appears in bug 229184. That bug has been
worked a bit more, so I'm resolving this as a dupe of that one.

*** This bug has been marked as a duplicate of 229184 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.