Double click repeatedly on white area in url bar causes crash

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Brian Krabbe, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
this occurs on any page that i load.  If i double click a few times in the
white area of the url bar seamonkey crashes.  The message it gives is:
MOZILLA caused an invalid page fault in
module GKHTML.DLL at 0177:60227839.
Registers:
EAX=01564b20 CS=0177 EIP=60227839 EFLGS=00010246
EBX=00000000 SS=017f ESP=0063fbc8 EBP=0063fc34
ECX=00000000 DS=017f ESI=00e3539c FS=5427
EDX=6027b0c0 ES=017f EDI=00e35390 GS=0000
Bytes at CS:EIP:
8b 01 ff 50 0c 5f 5e c2 04 00 8b 4c 24 0c 56 85
Stack dump:
01564b20 00ba2ea0 01564b20 6022ef10 01564b20 6022ed1f 00ba2ea0 00630000
00008c90 0063fc50 6022ec3e 00ba2ea0 bff72317 00000000 00000113 00000222

Occurs On Seamonkey (12/21/99 build on Windows 98)
Note that this doesnt occur in viewer.exe when i try the same thing.

Comment 1

19 years ago
Can't replicate this on NT (many attempts); this may be Windows 9x-only.

Tested with: 2000-01-01-08-M13 nightly binary on Windows NT 4.0sp3
(Reporter)

Comment 2

19 years ago
I tested this again with a later nightly build to see if it was fixed but it
still crashes me on win98 with build 2000010208

Comment 3

19 years ago
With 2000010208 Win95 (and at least one earlier build 95) I can't get this
to crash. However, Win98 has the spiffy 'roll-out' menus, so it's a slightly
different code base. [Gee, I wonder what it does with the spiffy
fade-in/fade-out menus on Win2K].
(Reporter)

Comment 4

19 years ago
I tested this at my work on an NTsp6 machine and it is ok here yet i am still
getting the crash at home.  Can someone test this on a win98 machine and see if
it might be something stupid im doing?   thanks.

Updated

19 years ago
Assignee: nobody → saari
Component: Browser-General → XPMenus
QA Contact: nobody → sairuh

Comment 5

19 years ago
Passing to saari/sairuh for XPMenus -- (Note: this seems to be specific
to Win98 menus).

Comment 6

19 years ago
(Although I'll modify my earlier inference: XPMenus don't really depend on
the system menu behaviour (AFAIK)).
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
Component: XPMenus → XPApps
QA Contact: sairuh → claudius
hmmm, this i believe falls under claudius' realm, so qa-reassigning to him. it
lies in the grey area btwn XPApps and XP Toolkit/widgets, too.

3jrgm@qlink.queensu.ca, have you tried this with a recent build on win98?
trudelle tried it today (win98, 20000105xx bits) and wasn't able to reproduce
it.

Comment 8

19 years ago
Sorry. Me no have win98. However, the original reporter for this bug,
omidk@email.com, noted on Jan 03 that it *does* crash on win98 for
build 2000010208 -- but (s)he would like someone else to try on win98
to confirm.

Comment 9

19 years ago
(Doh! me also no read well :-]) Since trudelle can't duplicate on win98,
then omidk@email.com : can you provide some more detail that may point
out if|why it happens on your box. Such as:
 * what are the messages in the console window,
 * which win98 specifically is this (there are two, right?),
 * have you *completely* nuked prior installs of Mozilla before
   installing a new nightly build (especially deleting your
   .\Seamonkey or .\bin directory before unzipping|installing),
 * anything else that comes to mind about how your win98 is "different"
Thanks.
(Reporter)

Comment 10

19 years ago
The Win98 machines that this is crashing on isnt service release 1 and i have
all of the most recent patches applied.  I usually install the zip file....i
delete old bin and user directories and delete mozregistry too.  im gonna try
it on a few of my friends win98 machines when i get home.
(Reporter)

Comment 11

19 years ago
I cant seem to reproduce this on another nearly identical win98 machine.
however i am still getting the crash on that win98 machine no matter what i do.
Could this be some sort of problem i may have with any dynamicilly linked
libraries i have that may be messed up??

Comment 12

19 years ago
I can't reproduce this on any Win32 machine. I gave it a try with several
flavors of Win98 (standard, SE2) and still no luck. I tried with 2000011108
builds. Normally, I'd just mark this WFM but if you can still repro this on
your machine with a brand new build and a really-really clean install AND
provide a useful stack trace, then it's up to saari as to what he wants to do
with this.
(Reporter)

Comment 13

19 years ago
well, i am the initial reporter of this bug and i can no longer reproduce it on
any machines that i have tried.  I had a completely clean install before but
this bug appears to be gone.  i guess it can be closed now.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 14

19 years ago
given the above comments, i am resolving as WFM

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
and marking VERIFIED.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.