Closed Bug 227472 Opened 21 years ago Closed 21 years ago

I get 11 empty unread messages with no subject or sender every time I switch mail folders

Categories

(MailNews Core :: Database, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: schase, Assigned: Bienvenu)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

I get 11 empty unread messages with no subject or sender every time I switch
mail folders. The messages are dated 12/31/1969 7:00 PM. If I delete them, they
come back if I switch mail folders or restart mozilla. This has been happening
for several months. I don't know what the cause could be. I updated my version
of mozilla a while back which may have caused problems.

Reproducible: Always

Steps to Reproduce:
1. Start mozilla.
2. Go to Inbox
3. See 11 empty messages dated 12/31/1969 7:00 PM
4. Delete empty messages
5. Switch to Trash folder
6. Switch back to Inbox and empty messages reappear

Actual Results:  
Repeated every time.

Expected Results:  
Never shown empty messages. Removed them permanently.
Are these IMAP or POP3/Local folders? I thought I'd fixed it so these messages
could at least be deleted. Can you send me the .msf files for the folders with
the empty messages so I can figure out why they can't be deleted?
Status: UNCONFIRMED → NEW
Ever confirmed: true
ok, I see why the deletes are failing - the message headers aren't in any
thread, so the delete code fails trying to remove them from their thread. So I
need to just remove them, period.
hmm, we are removing them in the code, but it seems not to be working. Will
investigate more when I get a chance. You can just remove the .msf files in
question and that will fix the problem for you.
I have the same problem, but it's just one unread message in one of my accounts
instead of 11.  Mine is dated 12/31/1969 6:00PM.  If I delete the .msf file, I
lose any e-mail in that folder, correct?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
No, deleting the .msf file won't lose any e-mail.
Attached patch proposed fixSplinter Review
this patch will remove ghost messages.
one problem this patch doesn't address is the potentially incorrect unread and
total counts for the folder due to these empty messages. I'm not sure if we
should try to adjust the unread+total counts here, or just worry about fixing
them elsewhere...
fix checked in. The phantom messages should disappear when you open the folder
(depending on your folder, it may take a few times for them to all disappear)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Why haven't the approval flags been set?
fixed on m4 branch
Comment on attachment 138649 [details] [diff] [review]
proposed fix

this is checked in on the branch but not the trunk...
Attachment #138649 - Flags: superreview?(mscott)
re-opening - shouldn't have marked fixed since the fix wasn't checked into the
trunk.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #138649 - Flags: superreview?(mscott) → superreview+
fixed - empty unread messages should disappear when you open the folder or the
thread, but it might take a few attempts.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: