Bookmarks file not read/saved when HKLU\Software\Microsoft\Windows\CurrentVersion\User Shell Folders\Favorites does not exist

VERIFIED DUPLICATE of bug 227471

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED DUPLICATE of bug 227471
15 years ago
14 years ago

People

(Reporter: Mirko Guldner, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.5) Gecko/20031007

If Registry entry
HKLU\Software\Microsoft\Windows\CurrentVersion\User Shell Folders\Favorites 
does not exist Mozilla seems to ignore all Bookmarks:

When Mozilla starts the bookmarks are not read; Mozilla shows no bookmarks (no
default bookmarks!); during the session it's possible to create new bookmarks;
when Mozilla is closed and restarted these bookmarks are gone; bookmarks.html
not touched. If a new profile is created there are no default bookmarks. All
this is true for Mozilla 1.4, 1.5 and 1.6a; Mozilla 1.3 works fine.

If the above registry setting exists everything works fine with Mozilla >1.3

Reproducible: Always

Steps to Reproduce:
1. (Note and) delete HKLU\Software\Microsoft\Windows\CurrentVersion\User Shell
Folders\Favorites
2. Start Mozilla 1.3, 1.4, 1.5 , 1.6: 1.3 shows Bookmarks, the others don't
3. Replace the Registy entry: Bookmarks are shown



Expected Results:  
Bookmarks should not depend on this Registry entry!

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 227471 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.