Links not launching properly when browser already open

RESOLVED DUPLICATE of bug 177996

Status

()

RESOLVED DUPLICATE of bug 177996
15 years ago
15 years ago

People

(Reporter: Lance, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031015 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031015 Firebird/0.7

When firebird is already running & a user clicks on an http:// link in an email
client (any client) the "select user profile" should not launch.  Idealy, the
requested link should open as a new Tab in the existing instance of Firebird.

A worse choice would be cleanly opening another instance of firebird as the same
user--but such a request should really open as a new Tab in the existing
instance of firebird.

The worst choice is the one that happens now--A new instance of firebird tries
to launch, then the "select user profile" interface launches.  Forcing the user
to a work around with ctrl-T and cutting & pasting URL's.


Reproducible: Always

Steps to Reproduce:
1. Launch Firebird
2. Click on any http link in any email client
Actual Results:  
A new instance of firebird tries to launch, then the "select user profile"
interface launches.  

Expected Results:  
Open the requested URL in a new Tab in the already running instance of Firebird.

Comment 1

15 years ago
This problem has been here with both Mozilla and Firebird for the past year. It
extends beyond clicking on email links. When working in Bluefish or Quanta if
you wish to preview a page the same error occurs. One is forced to kill any
existing browswer instance before being able to preview a page. 

In my opinion this is a major problem and a showstopper for me. I am forced to
used Nescase and Konqueror. I have not tried Opera lately for this. 

The -remote, openURL() and %s tags to dot seem to work with the new mozilla 1.4
or 1.5 or firebird .6 and .7



(Reporter)

Comment 2

15 years ago
Based on further information (Additional Comment #1) from Stephen Hancock on
2003-12-19, reporter is raising severity from minor to normal.
Severity: minor → normal
Summary: "select user profile" should not launch from email link → Links not launching properly when browser already open
Suggest marking this as a duplicate of bug #177996
(Reporter)

Comment 4

15 years ago
I now find two VERY old TRUNK bugs dealing with this same problem:

http://bugzilla.mozilla.org/show_bug.cgi?id=122698
http://bugzilla.mozilla.org/show_bug.cgi?id=177996

This bug is a major pain for new users trying out mozilla and/or firebird for
the first time.  I'm sure it's driving users away.  

I'm perfectly willing to relinquish this bug to either of the other bug reports,
but you should raise the severity of the other(s) to MAJOR.

Lance Haverkamp

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 177996 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.