Crash when page load fails while Firebird is hidden

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: frank kolodziej, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031204 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031204 Firebird/0.7+

When a site fails to load while Firebird is hidden, it will cause Firebird's
dock icon to bounce once, after which Firebird will crash.

Reproducible: Always

Steps to Reproduce:
0. Find a site that is down. A "Slashdotted site," for example. (The site I just
experienced the problem on was spymac.com, but it may or may not still be down
when this bug report is reviewed.)

1. attempt to access the site (type its address into the location bar, click on
a link from another site, it doesn't seem to matter).

2. while Firebird attempts to load the page, switch to another application (say,
the Finder), then access the Finder's application menu and select "Hide Others"
(or cmd+opt+h on the keyboard)

3. wait
Actual Results:  
When Firebird can't access the site, its dock icon bounces once or so, then the
app crashes, and then Panther's fancy "Submit Bug Report" dialog appears.

Expected Results:  
Bouncing the dock icon and then an error dialog. But not crashing.

I'm a designer, not a programmer, so this is purely a guess, but the crash might
have something to do with Firebird trying to draw the error dialog sheet.

Most of the time, I have all but the current application hidden, and I've
noticed that certain apps don't handle sheets properly when the program isn't
visible. For example, instead of the sheet being drawn attached to the window,
it's just drawn in the center of the screen, attached to nothing. This used to
happen with the app Cocktail.

Also, I'm using OS X v 10.3.1, and the default Pinstripe 3 theme.

I can provide crash logs if anybody wants to see them.

Comment 1

15 years ago
i used a non-existant url, and minimized the window, and it brought the window
back up to show me the dialog.  finding a url for this is going to be tricky :)
(Reporter)

Comment 2

15 years ago
Actually, if you're fast enough, a non-existant URL will cause the crash.

Type http://lkjweasdfjkdjfkadjf.com into the location bar, hit return/enter,
then quickly option+click an empty area of the desktop. That will hide Firebird
while bringing the Finder forward.

If done fast enough, I can get Firebird to crash every time.

Comment 3

15 years ago
Confirmed on Gecko/20031207 using the method described in Comment #2

Comment 4

15 years ago
No crash for me, works fine, following the instructions in comment 2.
Using 20031210 Firebird/0.7+, OS X 10.2.8

If Firebird is hidden when it decides that it can't find a URL, I hear a sound
and the Firebird icon jumps up and down on the dock. If I click on the icon, it
brings back the window with a dialog sheet telling me just that. No crash.

Wonder if it's a Panther problem. Marco, were you using 10.3 as well?

Unless it's coincidentally been fixed in the last few days...

Comment 5

15 years ago
Created attachment 137329 [details]
Crash log for #227504 on OS X 10.3.1

Comment 6

15 years ago
I'm running Panther, yes, and can still reproduce this on Gecko/20031212

Comment 7

15 years ago
OK, finally tried it out on 10.3 tonight and can reproduce the bug. 20031121
Firebird/0.7+ So obviously a Panther problem.

Comment 8

14 years ago
WFM Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b)
Gecko/20040406 Firefox/0.8.0+ on OSX.3.3

Comment 9

14 years ago
I have browser.xul.error.pages.enabled so keep this in mind...

WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a)
Gecko/20040420 Firefox/0.8.0+
WFM (as described in #2)

MacOS X.3.3

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040425
Firefox/0.8.0+
(Reporter)

Comment 11

14 years ago
I haven't experienced the problem since roughly 0.8 came out. I'm using nightly
builds of 0.8+ (the most recent being Mozilla/5.0 (Macintosh; U; PPC Mac OS X
Mach-O; en-US; rv:1.8a) Gecko/20040427 Firefox/0.8.0+) (OS 10.3.3), and it's
still fine.

Just yesterday morning, in fact, a site was down, and FF properly bounced its
dock icon instead of crashing like I originally reported.

Comment 12

14 years ago
wfm per Michael Kurze's testing
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.