Firebird crashes when opening Privacy on Tools->Options On Solaris Intel machines

RESOLVED DUPLICATE of bug 223964

Status

()

Firefox
Preferences
--
critical
RESOLVED DUPLICATE of bug 223964
15 years ago
12 years ago

People

(Reporter: Dragan Cvetkovic, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.79 [en] (X11; U; SunOS 5.10 i86pc; Nav)
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.5) Gecko/20031019 Firebird/0.7

When opening Privacy on Tools->Options, firebird crashes. If I attach gdb to it
before clicking on it, I get the following
Program received signal SIGSEGV, Segmentation fault.
0xdda7af75 in
__1cXnsSupportsWeakReferenceQGetWeakReference6MppnQnsIWeakReference__I_ () from
/usr/local/firebird0.7/MozillaFirebird/libxpcom.so

(gdb) bt
#0  0xdda7af75 in
__1cXnsSupportsWeakReferenceQGetWeakReference6MppnQnsIWeakReference__I_ () from
/usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#1  0xdda7ae5c in __1cSnsGetWeakReference2f6kMrknEnsID_ppv_I_ ()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#2  0xdda7af16 in
__1cTNS_GetWeakReference6FpnLnsISupports_pI_pnQnsIWeakReference__ () from
/usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#3  0xdd9f6986 in __1cOnsObserverListLAddObserver6MpnLnsIObserver_i_I_ ()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#4  0xdd9f7706 in __1cRnsObserverServiceLAddObserver6MpnLnsIObserver_pkci_I_ ()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#5  0x8d2b6c0 in __1cRnsPasswordManagerEInit6M_I_ ()
#6  0x8d41740 in __1cMnsPermissionNGetCapability6MpI_I_ ()
#7  0xdda7957b in
__1cQnsGenericFactoryOCreateInstance6MpnLnsISupports_rknEnsID_ppv_I_ () from
/usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#8  0xdda34c81 in
__1cWnsComponentManagerImplOCreateInstance6MrknEnsID_pnLnsISupports_rk1ppv_I_ ()
from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#9  0xdda34fb8 in __1cWnsComponentManagerImplKGetService6MrknEnsID_rk1ppv_I_ ()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#10 0xdda3d2c1 in
__1cQnsServiceManagerKGetService6FrknEnsID_rk1ppnLnsISupports_pnTnsIShutdownListener__I_
()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#11 0x8422a64 in __1cHnsJSCIDKGetService6MppnLnsISupports__I_ ()
#12 0xdda5ccbb in XPTC_InvokeByIndex ()
   from /usr/local/firebird0.7/MozillaFirebird/libxpcom.so
#13 0x842f254 in
__1cQXPCWrappedNativeKCallMethod6FrnOXPCCallContext_n0AICallMode__i_ ()
#14 0x84357e4 in __1cRXPC_WN_CallMethod6FpnJJSContext_pnIJSObject_Ipl4_i_ ()

For the information, here are my OS details:
% uname -a
SunOS lokrum 5.10 s10_44 i86pc i386 i86pc



Reproducible: Always

Steps to Reproduce:
1. Start firebird
2. Click on Tools->Options->Privacy
3. witness the crash

Actual Results:  
Crash (no core dump as far as I can see).

Expected Results:  
Opened the privacy tab.

Comment 1

15 years ago
Can you reproduce this with a more current build? A lot of changes have been
made to the Options since the 1.5 branch was cut.
(Reporter)

Comment 2

15 years ago
Created attachment 137143 [details]
This is the typescript and gdb backtrace of crash. 

This is the typescript and gdb backtrace of crash. Firebird was pulled from 
CVS today and compiled on Solaris 9. Directory $HOME/.phoenix was removed
before starting.

Comment 3

15 years ago
Per email conversation with Dragan, its crashing on a recent CVS build with a
new profile.

--> NEW
--> critical
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 4

15 years ago
Isn't it a dupe of Bug 223964(Clicking on 'Privacy' in Options crashes Firebird)?
indeed it is, based on the stacktrace.

*** This bug has been marked as a duplicate of 223964 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.