If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Select-one form objects with height style explicity set that has been openened, and parent visibility style is set to hidden, left gray area.

RESOLVED DUPLICATE of bug 206000

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 206000
14 years ago
12 years ago

People

(Reporter: Arcovia Software Bugs Support, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Debian/1.5-3

Select-one form objects with height style explicity set that has been openened
and selected another option, and any parent (contanier) object visibility style
is set to hidden, left gray area, still permanent in other workspaces, and out
of mozilla window, until parent object restore visibility status.

Reproducible: Always

Steps to Reproduce:
See on http://www.arcovia.com/mozillabug.html




On Mozilla 1.4 & 1.5
With WindowMaker and Sawfish (probably more)
Sounds like a gtk gfx bug...
Assignee: aaronlev5 → blizzard
Component: Accessibility APIs → GFX: Gtk
QA Contact: ian
Interesting.  This actually leaves zombie popups here.  That's not good. :)

Comment 3

14 years ago
Created attachment 148876 [details]
Open select elements leave visible gray patches when their visibility is set to hidden.

I think this bug is the same that I was about to report; though the provided
example did not behave for me as described. I'm therefore attaching a test case
for what I'm seeing; when opening a select element and then hiding it by
setting its visibility to hidden, a dark gray patch remains in the place of the
"opened" portion of the select box. The dark gray portion obscures anything
else on the page that is in the same area as the box. I'm on Windows NT here,
with Moz 1.7RC1. 

Let me know if this should be entered as a separate bug.

Comment 4

14 years ago
Please disregard my previous post and attachment; after submitting I realized I
was running an older Moz build when I created it (1.6, to be exact). When
running Moz 1.7 I do not see the problem. 
Well, I can see this still happening with the testcase, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/2004-05-14
And:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520
Firefox/0.8.0+

So this is not just Linux, but All I guess.
The URL's testcase is not working for me.

I have a testcase in which I don't have any height set for the drop down boxes,
so I'm changing the summary from:
"Select-one form objects with height style explicity set that has been openened,
and parent visibility style is set to hidden, left gray area."
to:
"Drop down boxes, left open, leave a gray area when their style is set to
visibility hidden"
if you don't mind.

I've seen this originally happening at http://www.tweakers.net, in the left
column in the middle of the page at "zoeken" (mouseover that one)
Created attachment 149071 [details]
Another testcase which shows the bug

Comment 7

13 years ago
Ok, I am now seeing this problem in both 1.7RC1 and 1.7 (final) Windows 2000.
Sorry to keep changing my mind on this, I'm not sure what I saw before that led
me to believe it was fixed in 1.7. I tried a couple different machines (NT/2000)
here today and I am consistently seeing the gray box on both of the attached
testcases. I'm still unable to recreate the problem on the original URL
reported, however.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

12 years ago
Assignee: blizzard → nobody
Status: UNCONFIRMED → NEW
Component: GFX: Gtk → Layout
Ever confirmed: true
Keywords: testcase
OS: Linux → All
QA Contact: ian → layout
Duplicate of bug 206000.

*** This bug has been marked as a duplicate of 206000 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.