Cannot delete mail in imap trash can.

VERIFIED FIXED in M13

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Jonm, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Can not delete the mail that has been deleted out of the inbox into the trash.
This is with a winNT 4.0 (SP5) system using build 1999122808.

Updated

19 years ago
Assignee: alecf → jefft
Component: Account Manager → Front End

Comment 1

19 years ago
interesting. I think this is Jefft's area, but CC'ing putterman

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Comment 2

19 years ago
Pop or Imap?

Updated

19 years ago
QA Contact: lchiang → esther
Summary: Can not delete mail in trash can. → Cannot delete mail in trash can.

Comment 3

19 years ago
esther - can you try this?

Comment 4

19 years ago
Looks like Imap delete messages in trash can is broken.

Comment 5

19 years ago
David, looks like your changes to revision 1.212 causes the regression.

Comment 6

19 years ago
The message is deleted but we failed to update the trash folder.

Comment 7

19 years ago
Created attachment 3942 [details] [diff] [review]
Possible fix. David, can you take a look? Thanks,
(Assignee)

Updated

19 years ago
Assignee: jefft → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 8

19 years ago
No, that's a bad fix. I'll fix it some other way. No additional protocol should
be required!
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Summary: Cannot delete mail in trash can. → Cannot delete mail in imap trash can.
(Assignee)

Comment 9

19 years ago
fixed (this was an imap only bug)

Comment 10

19 years ago
Using build 2000012109m13 on win98, 2000012108m13 on linux, 2000012108m13 on 
mac this is fixed.   In my IMAP account with my trash set up to "Move it to the 
trash folder", I deleted a message from my Inbox, then I clicked the Delete 
button to move it to the Trash.  I then selected it while in my Trash folder and 
clicked the Delete button again and the message was deleted.  I exited and 
restarted and the message was not in my trash.  Jonm, if this is not the correct 
scenario and the bug is still happening, please enter specific steps to 
reproduce it.  This is verified per my test scenario.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.