[1.x suite] when built with the suite, calendar needs a Window menu, like the other apps in the suite

VERIFIED WONTFIX

Status

Calendar
Sunbird Only
VERIFIED WONTFIX
15 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Details

(Assignee)

Description

15 years ago
[1.x suite] when built with the suite, calendar needs a Window menu, like the
other apps in the suire
(Assignee)

Updated

15 years ago
Summary: [1.x suite] when built with the suite, calendar needs a Window menu, like the other apps in the suire → [1.x suite] when built with the suite, calendar needs a Window menu, like the other apps in the suite

Comment 1

15 years ago
Calendar had the Window menu at one point but it was taken out:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=menuOverlay.xul&branch=&root=/cvsroot&subdir=mozilla/calendar/resources/content&command=DIFF_FRAMESET&rev1=1.46&rev2=1.47

The checkin comment reads:Removed dependency on tasksOverlay.xul to make
calendar available to thunderbird

The original problem was with thunderbird on windows which didn't include
tasksOverlay.dtd
( See bug 222049 )

I should add that the goal was to have unique calendar code that works on
suite/firebird/thunderbird rather than branching the code for each application.

Updated

15 years ago
Depends on: 222049

Comment 2

15 years ago
Scott,

This bug (actually, problem in tasksOverlay.xul of Thunderbird bug 222049) also
affect development of other extensions for suite/firebird/thunderbird/sunbird

So from a extension developers point of view Priority of this and bug 222049
should be highest

Comment 3

15 years ago
*** Bug 232139 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Also happens on Linux.

The Application Icons in the status bar are also missing, so there is no obvious
way to open another new Mozilla window when the Calendar window is the only one
left open.
OS: Windows 2000 → All

Comment 5

14 years ago
*** Bug 258778 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 257367

Updated

13 years ago
QA Contact: gurganbl → sunbird

Comment 6

12 years ago
xpi is dead.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.