Extremely slow saving of .JPG images from cache to disk.

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
15 years ago
3 years ago

People

(Reporter: gergely, Unassigned)

Tracking

({perf})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031206
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031206

I have included a sample URL above.  Load the page and then type Apple(Clover)-S
to "Save Page As ...".  Once you provide the destination, the program may sit
there for quite a few seconds, and then provide the spinning beachball.  After
some time (variable), it will save the file, and then return mouse control.

The first .JPG saved is longer than the next ones saved, but all take much too long.

To verify it is Mozilla, try the same thing in Safari, and the file save is
almost instantaneous after the destination is provided.

Reproducible: Always

Steps to Reproduce:
1.  Load any URL that contains a .JPG image
2.  Click on the image to open the image
3.  Select File/Save Page As... and provide the destination folder/directory and
click on the save button


Actual Results:  
Long delay usually resulting in a beach ball.
Possibly the progress box comes up.
Eventually mouse control is returned after the image is saved.

Basically, extremely long time to save image to disk.  It is as if the image is
being downloaded again, rather than using the cached image.  Safari doesn't
suffer this problem.

Expected Results:  
Comparable save times to Safari.
Assignee: darin → file-handling
Component: Networking: File → File Handling
QA Contact: benc → ian

Comment 1

15 years ago
Worksforme in build 2003120505 on Mac OS X 10.2.8

Updated

15 years ago
Keywords: perf
(Reporter)

Comment 3

15 years ago
This bug seems to have existed for a long time on my machine.  It was certainly
noticeable with 1.6a distribution, but has gotten worse with the daily updates
in 1.6b.

Comment 4

15 years ago
try deleting your downloads.rdf and see if its faster then ...
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Comment 7

13 years ago
The Bug still persists in 1.6a1 XP. Could someone reopen it?
Thanks.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.