location bar desynchronizes when closing tabs quickly

VERIFIED WORKSFORME

Status

()

Firefox
General
--
trivial
VERIFIED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Galileo Vidoni, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.5) Gecko/20031007

it is really a minor bug, but if you have a lot of tabs open and start closing
them quickly with ctrl+w, the location bar des-synchronizes with the tab's page
URL. this means that when you reach the first tab in the list, the URL displayed
in the location bar shows the one form another tab, then from the other, and so
up it reaches the current tab's URL. it doesn't seems to happen in seamonkey.

Reproducible: Always

Steps to Reproduce:
1.open a lot of tabs
2.close them quickly with ctrl+w until you reach the first one
3.look the location bar

Actual Results:  
there appeared the URLs of the past tabs

Expected Results:  
shown the URL of the tab when if was in front, and now show directly the first
teb's URL

Comment 1

15 years ago
WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031207
Firebird/0.7+.  Some of the URLs are skipped, but when I pause, the correct URL
is always shown.

Please test with a nightly build from December 5 or later, because another bug
with tabs and the address bar was fixed then (bug 203102).  I recommend a
December 7 build.
Summary: location bar des-synchronizes when closing tabs too quickly → location bar desynchronizes when closing tabs quickly

Comment 2

15 years ago
Worksforme with a current build. You're using a very old build. Please only
report bugs when using a current nightly build.

-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: bugzilla
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.