Double-clicking on scoll arrow in options : downloads : file types acts like double-clicking on an item

VERIFIED FIXED

Status

()

Firefox
Preferences
P4
minor
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Greg Campbell, Assigned: Blake Ross)

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031207 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031207 Firebird/0.7+

The scrollbar widget registers a double-click when you quickly click the
scrollbar arrows repeatedly.

Reproducible: Always

Steps to Reproduce:
1. Go to the File Types box and click any entry to select it.
2. Click a scrollbar arrow quickly to scroll through the list.


Actual Results:  
The Change Action dialog appears for the currently selected item.

Expected Results:  
Just scroll like any normal scrolling box.

Comment 1

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031207
Firebird/0.7+
Win XP Pro SP1

I can reproduce this bug.  Do not forget to select a file type in the box, if
there is no selection the scroll bar functions as expected.

Updated

15 years ago
Summary: scrolling triggers double-click in options : downloads : file types → Double-clicking on scoll arrow in options : downloads : file types acts like double-clicking on an item

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
This bug occurs in the latest milestone:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

And the 20040221 trunk by Kreuger

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040221
Freebird/0.8.0+ (Krueger)
*** Bug 237747 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
The patch from Bug 215928 fixes this for me.

p.s. It would be nice if there was some sort of procedure in place to stop
Firefox from missing out on all these little Seamonkey chrome patches.
Bug 227742 was fixed last year. But I can confirm this one with Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040329 Firefox/0.8.0+

1. Select first entry
2. DblClick on scrollbar
-> dialog opens

Comment 6

14 years ago
I meant applying the Seamonkey patch from Bug 227742 to Firefox fixes this for
me :-)

Comment 7

14 years ago
*** Bug 239815 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 236785 has been marked as a duplicate of this bug. ***
(In reply to comment #6)
> I meant applying the Seamonkey patch from Bug 227742 to Firefox fixes this for
> me :-)

I think you mean Bug 215928. So applying it to FF? 

Comment 10

14 years ago
Created attachment 146385 [details] [diff] [review]
Toolkit version of patch from Bug 215928 (Obsolete)

Yeah that's what I meant :-) This patch by Neil in Bug 215928 WFM.
(Reporter)

Updated

14 years ago
Flags: blocking1.0?

Comment 11

14 years ago
Comment on attachment 146385 [details] [diff] [review]
Toolkit version of patch from Bug 215928 (Obsolete)

Looks like they changed their mind on this, see Bug 237998 for plan B.
Attachment #146385 - Attachment description: Toolkit version of patch from Bug 215928 → Toolkit version of patch from Bug 215928 (Obsolete)
Attachment #146385 - Attachment is obsolete: true

Comment 12

14 years ago
Reproduced it here as well.
Not trying to **** people off but
why aren't these kind of bugs targeted for 0.9? I think 0.9 has to be delayed to
fix these bugs, just my 2 cents.

Comment 13

14 years ago
Reproduced it here as well.
Not trying to **** people off but
why aren't these kind of bugs targeted for 0.9? I think 0.9 has to be delayed to
fix these bugs, just my 2 cents.
because its more important to ship 0.9 sooner and get more feedback on bugs in 
the major new features before the 1.0 release.  This is bordering on trivial 
and doesn't need to be fixed for a pre-1.0 milestone.

Comment 15

14 years ago
(In reply to comment #14)
> because its more important to ship 0.9 sooner and get more feedback on bugs in 
> the major new features before the 1.0 release.  This is bordering on trivial 
> and doesn't need to be fixed for a pre-1.0 milestone.

Okay, that makes sence indeed :)
Flags: blocking1.0? → blocking1.0+

Comment 16

14 years ago
*** Bug 245303 has been marked as a duplicate of this bug. ***
Priority: -- → P4
(Assignee)

Comment 17

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 18

14 years ago
*** Bug 254570 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: fixed-aviary1.0
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.